OpenWrt/LEDE Project

  • Status Assigned
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Koen Vandeputte
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Alexander Krause - 19.11.2018

FS#1962 - PIN verify with QMI on Quectel EC-25A

I’m trying to get wwan running on GL.Inet MiFi (Quectel EC-25A cellular modem PCIE).

OpenWrt shows “Error: PIN code rejected”.

I tried to use uqmi to check if PIN stuff works:
root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 –verify-pin1 5161
“Not supported”

root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 –uim-verify-pin1 5161
“Invalid arguments given”

root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 –uim-verify-pin1 “PIN,5161” “Incorrect PIN

I found this patch which tells me the PIN argument for verify and uim-verify should be the same, but it seems it isn’t.
http://lists.infradead.org/pipermail/lede-commits/2017-December/005176.html

Project Manager
Koen Vandeputte commented on 13.12.2018 23:55

I'll check this tomorrow.
Ive got such device and modem.

Koen

Project Manager
Koen Vandeputte commented on 14.12.2018 13:52

Checked on a freshly build 18.06 and a gl.MiFi with a EC25-E

root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 –verify-pin1 1111
"Not supported"
root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 –uim-verify-pin1 1111
root@OpenWrt:~#

After the UIM cmd, the pin is unlocked properly.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing