OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by shanicoolest - 14.11.2018

FS#1950 - XWAY / BT Home Hub 2B - Wifi Random Disconnects Repeatedly on WDS AP+STA Mode

Very annoying wifi disconnects when connected to WDS-Repeater.
The AP works no disconnects but when connected to repeater random disconnects repeatedly.
Affected firmware release both LEDE 17.X.X and Openwrt 18.X.X

Note: Checked, WDS works fine on Previous Openwrt Releases(BarrierBreaker, ChaosCalmer) on same settings
https://openwrt.org/docs/guide-user/network/wifi/atheroswds

Attaching AP and Repeater Logs:

AP Config:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '5'
	option hwmode '11ng'
	option path 'pci0000:00/0000:00:0e.0'
	option htmode 'HT20'
	option country 'US'
	option txpower '22'
	option log_level '1'
	option macaddr 'be:b5:1b:b5:70:47'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'MyAP'
	option wds '1'
	option encryption 'psk2+ccmp'
	option key 'password'
	option wmm '1'

Repeater WDS Config:
Network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd4:7f11:dd9a::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4'

Wireless WDS:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '5'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option htmode 'HT20'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'sta'
	option wds '1'
	option ssid 'MyAP'
	option bssid 'be:b5:1b:b5:70:47'
	option encryption 'psk2+ccmp'
	option key 'password'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'MyAP'
	option encryption 'psk2+ccmp'
	option key 'password'
	option wmm '1'

Repeater WDS Log:

Wed Nov 14 12:26:05 2018 daemon.notice netifd: Network device 'wlan0' link is down
Wed Nov 14 12:26:05 2018 kern.info kernel: [ 5805.077610] br-lan: port 3(wlan0) entered disabled state
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:05 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:06 2018 daemon.notice netifd: Network device 'wlan0-1' link is down
Wed Nov 14 12:26:06 2018 kern.info kernel: [ 5806.068825] br-lan: port 2(wlan0-1) entered disabled state
Wed Nov 14 12:26:07 2018 daemon.notice netifd: bridge 'br-lan' link is down
Wed Nov 14 12:26:07 2018 daemon.notice netifd: Interface 'lan' has link connectivity loss
Wed Nov 14 12:26:07 2018 daemon.notice netifd: lan (1163): udhcpc: received SIGTERM
Wed Nov 14 12:26:07 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.220211] wlan0: authenticate with be:b5:1b:b5:70:47
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.243173] wlan0: send auth to be:b5:1b:b5:70:47 (try 1/3)
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.257141] wlan0: authenticated
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.268771] wlan0: associate with be:b5:1b:b5:70:47 (try 1/3)
Wed Nov 14 12:26:09 2018 daemon.notice netifd: Network device 'wlan0' link is up
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.282394] wlan0: RX AssocResp from be:b5:1b:b5:70:47 (capab=0x431 status=0 aid=5)
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.290756] wlan0: associated
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.309766] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:09 2018 kern.info kernel: [ 5809.315545] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:09 2018 daemon.notice netifd: bridge 'br-lan' link is up
Wed Nov 14 12:26:09 2018 daemon.notice netifd: Interface 'lan' has link connectivity 
Wed Nov 14 12:26:09 2018 daemon.notice netifd: Interface 'lan' is setting up now
Wed Nov 14 12:26:09 2018 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED 00:00:00:00:00:14
Wed Nov 14 12:26:09 2018 daemon.notice netifd: lan (1293): udhcpc: started, v1.25.1
Wed Nov 14 12:26:09 2018 daemon.notice netifd: lan (1293): udhcpc: sending discover
Wed Nov 14 12:26:09 2018 daemon.notice netifd: lan (1293): udhcpc: sending select for 192.168.1.117
Wed Nov 14 12:26:09 2018 daemon.notice netifd: lan (1293): udhcpc: lease of 192.168.1.117 obtained, lease time 43200
Wed Nov 14 12:26:09 2018 daemon.notice netifd: Interface 'lan' is now up
Wed Nov 14 12:26:10 2018 kern.info kernel: [ 5810.201396] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:26:10 2018 kern.info kernel: [ 5810.207348] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:26:10 2018 daemon.notice netifd: Network device 'wlan0-1' link is up
Wed Nov 14 12:26:11 2018 kern.info kernel: [ 5811.308642] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:12 2018 kern.info kernel: [ 5812.198553] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:26:16 2018 daemon.info hostapd: wlan0-1: STA 00:00:00:00:00:14 IEEE 802.11: authenticated
Wed Nov 14 12:26:16 2018 daemon.info hostapd: wlan0-1: STA 00:00:00:00:00:14 IEEE 802.11: associated (aid 1)
Wed Nov 14 12:26:16 2018 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED 00:00:00:00:00:14
Wed Nov 14 12:26:16 2018 daemon.info hostapd: wlan0-1: STA 00:00:00:00:00:14 WPA: pairwise key handshake completed (RSN)
Wed Nov 14 12:26:25 2018 daemon.notice netifd: Network device 'wlan0' link is down
Wed Nov 14 12:26:25 2018 kern.info kernel: [ 5825.168505] br-lan: port 3(wlan0) entered disabled state
Wed Nov 14 12:26:25 2018 kern.info kernel: [ 5825.949685] wlan0: authenticate with be:b5:1b:b5:70:47
Wed Nov 14 12:26:25 2018 kern.info kernel: [ 5825.972671] wlan0: send auth to be:b5:1b:b5:70:47 (try 1/3)
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice netifd: Network device 'wlan0-1' link is down
Wed Nov 14 12:26:26 2018 kern.info kernel: [ 5826.168126] br-lan: port 2(wlan0-1) entered disabled state
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 kern.info kernel: [ 5826.788061] wlan0: send auth to be:b5:1b:b5:70:47 (try 2/3)
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:26:26 2018 kern.info kernel: [ 5826.988066] wlan0: send auth to be:b5:1b:b5:70:47 (try 3/3)
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.008409] wlan0: authenticated
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.018301] wlan0: associate with be:b5:1b:b5:70:47 (try 1/3)
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.085692] wlan0: RX AssocResp from be:b5:1b:b5:70:47 (capab=0x431 status=0 aid=5)
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.094030] wlan0: associated
Wed Nov 14 12:26:27 2018 daemon.notice netifd: Network device 'wlan0' link is up
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.156807] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.162628] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:27 2018 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED 00:00:00:00:00:14
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.606090] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:26:27 2018 kern.info kernel: [ 5827.612066] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:26:27 2018 daemon.notice netifd: Network device 'wlan0-1' link is up
Wed Nov 14 12:26:29 2018 kern.info kernel: [ 5829.157978] br-lan: port 3(wlan0) entered forwarding state
Wed Nov 14 12:26:29 2018 kern.info kernel: [ 5829.607947] br-lan: port 2(wlan0-1) entered forwarding state
Wed Nov 14 12:27:02 2018 daemon.notice netifd: Network device 'wlan0' link is down
Wed Nov 14 12:27:02 2018 kern.info kernel: [ 5862.141503] br-lan: port 3(wlan0) entered disabled state
Wed Nov 14 12:27:02 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:27:02 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.517323] ------------[ cut here ]------------
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.522138] WARNING: CPU: 0 PID: 980 at compat-wireless-2017-01-31/net/mac80211/ieee80211_i.h:1011 0x80d84e80 [mac80211@80d80000+0x607a0]()
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.535171] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_coWed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.600905] CPU: 0 PID: 980 Comm: hostapd Not tainted 4.4.153 #0
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] Stack : 803938d8 00000000 00000001 803f0000 00000000 00000000 00000000 00000000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.607127] 	  ...
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.644169] Call Trace:[<80071c44>] 0x80071c44
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.648814] [<80071c44>] 0x80071c44
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.652426] [<80081ac8>] 0x80081ac8
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.656035] [<80d84e80>] 0x80d84e80 [mac80211@80d80000+0x607a0]
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.662174] [<80081b80>] 0x80081b80
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.665784] [<80118460>] 0x80118460
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.669414] [<80d84e80>] 0x80d84e80 [mac80211@80d80000+0x607a0]
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.675533] [<80118460>] 0x80118460
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.679174] [<80d9f1cc>] 0x80d9f1cc [mac80211@80d80000+0x607a0]
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.685292] [<80118460>] 0x80118460
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.688933] [<80cda8bc>] 0x80cda8bc [cfg80211@80cc0000+0x36ba0]
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.695047] [<80118460>] 0x80118460
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.698680] [<802a6384>] 0x802a6384
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.702289] [<802a4b94>] 0x802a4b94
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.705911] [<802a60f0>] 0x802a60f0
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.709534] [<802a54d0>] 0x802a54d0
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.713145] [<80400000>] 0x80400000
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.716753] [<802a60d8>] 0x802a60d8
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.720376] [<80268dd0>] 0x80268dd0
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.723986] [<802a4d34>] 0x802a4d34
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.727610] [<802682d4>] 0x802682d4
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.731228] [<802a52ac>] 0x802a52ac
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.734829] [<801bd428>] 0x801bd428
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.738447] [<8026cb54>] 0x8026cb54
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.742065] [<8025e448>] 0x8025e448
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.745677] [<8025f860>] 0x8025f860
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.749308] [<8025e448>] 0x8025e448
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.752914] [<802604a4>] 0x802604a4
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.756538] [<80260790>] 0x80260790
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.760162] [<800b2f2c>] 0x800b2f2c
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.763782] [<80062c6c>] 0x80062c6c
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.767401] 
Wed Nov 14 12:27:03 2018 kern.warn kernel: [ 5862.768949] ---[ end trace 3926c6523a1013c9 ]---

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing