OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Toolchain
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Petrus - 30.10.2018
Last edited by Jo-Philipp Wich - 13.11.2018

FS#1918 - openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86 _64 can't compile any package

Device: Linksys WRT1200AC
Environment: Ubuntu 18.04
SDK: Openwrt 18.06.01 release, https://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64.tar.xz Package: https://github.com/shadowsocks/openwrt-shadowsocks Steps to reproduce:

tar xaf openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64.tar.xz
cd openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64
git clone https://github.com/shadowsocks/openwrt-feeds.git package/feed
git clone https://github.com/shadowsocks/openwrt-shadowsocks.git package/shadowsocks-libev
make menuconfig
make package/shadowsocks-libev/compile V=99


WARNING: Makefile 'package/feeds/packages/libsodium/Makefile' has a build dependency on 'libtool', which does not exist
WARNING: Makefile 'package/feeds/packages/libsodium/Makefile' has a build dependency on 'gettext', which does not exist
WARNING: Makefile 'package/feeds/packages/libsodium/Makefile' has a build dependency on 'libiconv', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'r8169-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'e100-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'bnx2-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'ar3k-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'mwifiex-sdio-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'kmod-phy-bcm-ns-usb2', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'edgeport-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'kmod-phy-bcm-ns-usb3', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'prism54-firmware', which does not exist
WARNING: Makefile 'package/linux/Makefile' has a dependency on 'rtl8192su-firmware', which does not exist
WARNING: Makefile 'package/shadowsocks-libev/Makefile' has a dependency on 'zlib', which does not exist
WARNING: Makefile 'package/shadowsocks-libev/Makefile' has a dependency on 'zlib', which does not exist
WARNING: Makefile 'package/shadowsocks-libev/Makefile' has a build dependency on 'libpcre', which does not exist
WARNING: Makefile 'package/shadowsocks-libev/Makefile' has a build dependency on 'libmbedtls', which does not exist
tmp/.config-package.in:36:warning: ignoring type redefinition of 'PACKAGE_libc' from 'boolean' to 'tristate'
tmp/.config-package.in:64:warning: ignoring type redefinition of 'PACKAGE_libgcc' from 'boolean' to 'tristate'
tmp/.config-package.in:149:warning: ignoring type redefinition of 'PACKAGE_libpthread' from 'boolean' to 'tristate'
#
# configuration written to .config
#
make[1]: Entering directory '/root/openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64'
env: 'time': No such file or directory
package/Makefile:107: recipe for target 'package/toolchain/compile' failed
make[1]: *** [package/toolchain/compile] Error 127
make[1]: Leaving directory '/root/openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64'
/root/openwrt-sdk-18.06.1-mvebu-cortexa9_gcc-7.3.0_musl_eabi.Linux-x86_64/include/toplevel.mk:209: recipe for target 'package/shadowsocks-libev/compile' failed
make: *** [package/shadowsocks-libev/compile] Error 2


Closed by  Jo-Philipp Wich
13.11.2018 12:49
Reason for closing:  Not a bug
Admin
Jo-Philipp Wich commented on 13.11.2018 12:49

Install the standalone "GNU time" package.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing