OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by oso21 - 29.09.2018
Last edited by Jonas Gorski - 21.01.2019

FS#1871 - Kernel :Ipq806x MTD ECC ERROR

Kernel Version :4.14.72
Device :R7800 R7500v2
Problem Desrciption : low performance and unable to access later on

Partial Kernel log as below:
[ 13.139004] mount_root: loading kmods from internal overlay
[ 13.160507] kmodloader: loading kernel modules from etc/modules-boot.d/*
[ 13.162142] kmodloader: done loading kernel modules from
etc/modules-boot.d/*
[ 13.645897] print_req_error: I/O error, dev mtdblock0, sector 0
[ 13.646480] print_req_error: I/O error, dev mtdblock0, sector 8
[ 13.651170] print_req_error: I/O error, dev mtdblock0, sector 16
[ 13.657141] print_req_error: I/O error, dev mtdblock0, sector 24
[ 13.663652] print_req_error: I/O error, dev mtdblock0, sector 0
[ 13.668768] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[ 13.675464] print_req_error: I/O error, dev mtdblock1, sector 0
[ 13.682197] print_req_error: I/O error, dev mtdblock1, sector 8
[ 13.688189] print_req_error: I/O error, dev mtdblock1, sector 16
[ 13.694064] print_req_error: I/O error, dev mtdblock1, sector 24
[ 13.700333] print_req_error: I/O error, dev mtdblock1, sector 0
[ 13.705746] Buffer I/O error on dev mtdblock1, logical block 0, async page read
[ 14.652468] UBIFS (ubi0:1): default file-system created
[ 14.863310] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” started, PID 145
[ 15.992981] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name “rootfs_data” [ 15.993012] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[ 15.999790] UBIFS (ubi0:1): FS size: 86851584 bytes (82 MiB, 684 LEBs), journal size 4317184 bytes (4 MiB, 34 LEBs)
[ 16.009776] UBIFS (ubi0:1): reserved for root: 4102214 bytes (4006 KiB)
[ 16.020007] UBIFS (ubi0:1): media format: w4/r0 (latest is w5/r0), UUID F5E27DA8-5132-4007-B493-3B43B43C9591, small LPT model
[ 16.027856] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[ 16.038233] block: unable to load configuration (fstab: Entry not found)
[ 16.044908] block: attempting to load /tmp/ubifs_cfg/etc/config/fstab
[ 16.051793] block: unable to load configuration (fstab: Entry not found)
[ 16.058205] block: attempting to load /etc/config/fstab
[ 16.065988] block: unable to load configuration (fstab: Entry not found)
[ 16.069806] block: no usable configuration
[ 16.119510] UBIFS (ubi0:1): un-mount UBI device 0
[ 16.119592] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” stops
[ 16.128471] UBIFS (ubi0:1): background thread “ubifs_bgt0_1” started, PID 146
[ 16.705716] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name “rootfs_data” [ 16.705748] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[ 16.712618] UBIFS (ubi0:1): FS size: 86851584 bytes (82 MiB, 684 LEBs), journal size 4317184 bytes (4 MiB, 34 LEBs)
[ 16.722502] UBIFS (ubi0:1): reserved for root: 4102214 bytes (4006 KiB)
[ 16.732746] UBIFS (ubi0:1): media format: w4/r0 (latest is w5/r0), UUID F5E27DA8-5132-4007-B493-3B43B43C9591, small LPT model
[ 16.754840] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[ 16.757717] Buffer I/O error on dev mtdblock1, logical block 0, async page read
[ 17.872520] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[ 17.872644] block: unable to load configuration (fstab: Entry not found)
[ 17.878349] block: attempting to load /tmp/ubifs_cfg/etc/config/fstab
[ 17.885464] block: unable to load configuration (fstab: Entry not found)
[ 17.891622] block: attempting to load /etc/config/fstab
[ 17.898506] block: unable to load configuration (fstab: Entry not found)
[ 17.903495] block: no usable configuration

Closed by  Jonas Gorski
21.01.2019 10:35
Reason for closing:  Not a bug
Additional comments about closing:  

The first few blocks of a NAND flash are guaranteed good to ensure that a bootloader stored there can never get corrupted, so it will get written without valid ECC data (the SoC won't check the ECC anyway).

When block-mount scans all block devices, it will try to read from those blocks, which are exposed as partitions, and the NAND driver will report failed ECC checks (the I/O errors in the log).

There is nothing wrong here in either way, and nothing we can really do to prevent it.

Paul Oranje commented on 19.01.2019 17:24

Only happens when block-mount is installed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing