OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Jaime Towns - 11.09.2018
Last edited by Petr Štetiar - 29.05.2019

FS#1842 - BT Home Hub 2B (lantiq) has nand / ubi errors on boot with 18.06.1

I’ve flashed my BT Home Hub 2B with OpenWrt 18.06.1 (using sysupgrade) and it boots (just!) but the log shows a lots of errors during boot.

I’ve attached the boot log produced via a serial console.

Previously to me flashing this router with openwrt 18.06.1, it was running lede 17.01.4 with no errors.

Closed by  Petr ┼átetiar
29.05.2019 09:18
Reason for closing:  Fixed
Additional comments about closing:  

Requested.

Jaime Towns commented on 11.09.2018 16:55

I forgot to mention that https://bugs.openwrt.org/index.php?do=details&task_id=245 looks similar (same architecture and similar error messages) - perhaps this bug is related.

Jaime Towns commented on 12.09.2018 13:02

More info: I force-flashed the router back down to (lede) release 17.01.4 and I see very similar errors on boot, so I now think that my previous "belief" (that I was "running lede 17.01.4 with no errors") is incorrect. I now think that the nand on this router is failing and that therefore the router needs to be binned/thrown away. I have attached the "17.01.4.bootlog" - could anyone please confirm whether or not the nand on this router is broken? Many thanks.

Jaime Towns commented on 13.09.2018 12:58

OK, more info. Instead of reflashing by running sysupgrade from within a running openwrt, I booted the initramfs from the Porta-Danube prompt and then (once that had booted) I ran sysupgrade from there. This worked perfectly for the first couple of hours (no more nand/ubifs errors at all) but then the router rebooted itself (?!), and then the nand/ubifs errors all returned. I'm beginning to think that the nand/ubifs errors are simply the result of instant reboots caused by either me pulling the power or kernel crashes combined with a new sync semantic whereby an unclean shutdown will trash the ubifs filesystem (I'm guessing here!!)

I'm going to bail out of this and go back to 17.01.4 until I have the time to work out what's going on.

Jaime Towns commented on 13.09.2018 13:03
Jaime Towns commented on 16.05.2019 19:42

I'm not sure when this was fixed, but I've been running 18.06.2 on three different HH2Bs for a couple of weeks now, and they all seem to be working perfectly. Closing this bug now. Many thanks. JT

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing