OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Koen Vandeputte
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Vladimír Záhradník - 02.09.2018
Last edited by Koen Vandeputte - 29.10.2018

FS#1830 - Mikrotik: sysupgrade fails due to ubifs dropped support for MLC NAND flash

Device problem occurs on Mikrotik RB450G and all other devices with MLC NAND flash, which use UBIFS on their flash

Affected software versions of OpenWrt/LEDE:
Issue occurrs on LEDE 17.01.5 and newer, including latest builds from trunk (dc9388a on master)

Description:
According to this message on LKML, UBIFS driver never supported MLC NAND flash and now the support was explicitly disabled. Linux kernels having this patch applied refuse to mount the UBI file system from MLC NAND mtd device.

https://lore.kernel.org/patchwork/patch/920344/

Before this patch, user could encounter data loss on such flash chip, but at least he was able to mount the filesystem. At the moment, all supported Mikrotik routers use ubifs for their flash. If user is running older openwrt/lede and performs sysupgrade to latest openwrt, the upgrade will fail and will make the router non-working, because the linux kernel will not mount the filesystem anymore. And if user tries to perform fresh install, it will also fail.

At the moment I did rollback to LEDE 17.01.4 in order to have the router at least in a working state.

- Steps to reproduce

 Try to install latest Openwrt 18.06.1 on Mikrotik router with MLC NAND flash. Install should fail.

I think that at the moment when there’s no other way (as far as I’m aware) to flash OpenWrt on Mikrotik, it would be great to patch the kernel to mount the filesystem, effectively restoring old behavior as in LEDE 17.01.4. If this is not acceptable for you, at least Wiki pages should be updated, warning users to avoid upgrading and stating LEDE 17.01.4 as the last supported version.

Attached is the log from failed Openwrt install.


Closed by  Koen Vandeputte
29.10.2018 10:00
Reason for closing:  Fixed
Additional comments about closing:  

Fixed for 18.06 branch only.

This patch won't probably make it's way to Master as upstream officially ended support for MLC in this usecase.

Vladimír Záhradník commented on 02.09.2018 13:39

Attached logs.

Project Manager
Koen Vandeputte commented on 18.10.2018 14:55
Project Manager
Koen Vandeputte commented on 22.10.2018 11:04

Hi,

Just to validate that the chip is indeed MLC,
and it's not wrongfully detected, could you please:

- Check the board and share the exact nand flash type as printed on the chip itself?
- Provide a full dmesg log

Thanks

Project Manager
Christian Lamparter commented on 25.10.2018 21:54

This issue found its way to the mailing-list: [OpenWrt-Devel] [PATCH] kernel: tolerate using UBI/UBIFS on MLC flash (FS#1830)

And the openwrt developer Koen Vandeputte has issued an request for serial numbers of affected RouterBoards.

There is also a related bugreport: FS#1778

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing