OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 2
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Ansuel - 17.09.2016
Last edited by Jo-Philipp Wich - 30.11.2016

FS#182 - host/u-boot-2014.10 compilation error with OpenSSL 1.1+

/home/Ansuel/lede/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c: In function 'rsa_get_exponent':
/home/Ansuel/lede/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c:279:21: error: dereferencing pointer to incomplete type 'RSA {aka struct rsa_st}'
  if (BN_num_bits(key->e) > 64)
                     ^~
scripts/Makefile.host:134: recipe for target 'tools/lib/rsa/rsa-sign.o' failed

I compile with default .config (i had one with all my settings, i reset it to test if it was my problem..) the only thing that i changes are binutils 1.26 version and gcc 6.x

Any idea?

Closed by  Jo-Philipp Wich
30.11.2016 17:22
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with 70b104f

Admin
Jo-Philipp Wich commented on 06.10.2016 14:37

Buildbots seem to have no problem building uboot host utilities. I suppose something is wrong with the OpenSSL/LibreSSL headers on your host system.

J commented on 23.11.2016 00:46

I just hit this on my Debian unstable desktop.

The new OpenSSL seems to have broken some things.

I think this is the same thing but didn't look too close:

https://www.mail-archive.com/u-boot@lists.denx.de/msg228491.html

Olof Sivertsson commented on 23.11.2016 20:10

Your compilation error is probably caused by this OpenSSL 1.1 change:
Made RSA and RSA_METHOD opaque. The structures for managing RSA objects have been moved out of the public header files. New functions for managing these have been added. (From https://www.openssl.org/news/cl110.txt)

A workaround on Debian unstable is

apt install libssl1.0-dev

to downgrade your OpenSSL headers.

hngsvtdu@sharklasers.com commented on 25.11.2016 09:53

I made the downgrade from openssl/libssl 1.1.0c to 1.0.2j. Seems to be working fine. Its compiling now for long time where before the error appear after just few seconds.

I think this bug should still have high priority. Many OS would be updated next days to 1.1.0 . For example on arch linux recent 1.0.2j Version is been tagged as outdated in their packages and would probably be updated quickly.

Openssl 1.1.0 is already a stable release.

https://www.openssl.org/source/

hngsvtdu@sharklasers.com commented on 25.11.2016 09:54

The more recent and still open LEDE-bugreport about the same error:

https://bugs.lede-project.org/index.php?do=details&task_id=297

J commented on 25.11.2016 10:46

Seems to be an openssl 1.1 issue.

hngsvtdu@sharklasers.com commented on 30.11.2016 16:07

No, its not a openssl issue. Just read the changelog and the notes about the security related changes from openssl 1.0 to 1.1.

Admin
Jo-Philipp Wich commented on 30.11.2016 17:22

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing