Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1652 - ipq40xx : Configure (CPU)eth0 as tagged port fails #6586

Open
openwrt-bot opened this issue Jul 14, 2018 · 1 comment
Open

FS#1652 - ipq40xx : Configure (CPU)eth0 as tagged port fails #6586

openwrt-bot opened this issue Jul 14, 2018 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

ish00t:

Router type : Asus RT-AC58U
Version : OpenWrt SNAPSHOT, r7478-16035a7
Target : ipq40xx

VLAN’s on the switch work fine with tagged and untagged physical Ethernet ports, but when (CPU)eth0 is configured as tagged port then communication between CPU(eth0) and devices attached to the switch fails.

======Working config :======

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd80:cae7:38f3::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.4'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
option ip6assign '60'
option ifname 'eth0'

config device 'lan_dev'
option name 'eth0'
option macaddr 'b0:6e:bf:a9:79:08'

config interface 'wan'
option ifname 'eth1'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '172.16.1.1'

config device 'wan_dev'
option name 'eth1'
option macaddr 'b0:6e:bf:a9:79:0c'

config interface 'wan6'
option ifname 'eth1'
option proto 'none'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 1t 2 4'

config interface 'VPN'
option proto 'none'
option ifname 'tun0'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '3'
option ports '1t 3'

======NOT working config :======

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd80:cae7:38f3::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.4'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
option ip6assign '60'
option ifname 'eth0.1'

config device 'lan_dev'
option name 'eth0'
option macaddr 'b0:6e:bf:a9:79:08'

config interface 'wan'
option ifname 'eth1'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '172.16.1.1'

config device 'wan_dev'
option name 'eth1'
option macaddr 'b0:6e:bf:a9:79:0c'

config interface 'wan6'
option ifname 'eth1'
option proto 'none'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1t 2 4'

config interface 'VPN'
option proto 'none'
option ifname 'tun0'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '3'
option ports '1t 3'

@openwrt-bot
Copy link
Author

game:

I experienced the same issue on The AVM Fritz!Box 4040.
See this thread: https://forum.openwrt.org/t/setting-up-vlan-on-avm-fritz-box-4040-not-working/32767?u=game

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant