OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by neheb - 07.09.2016

FS#162 - Two issues with libuclient-openssl in luci-ssl

1: RC4 and 3DES are used when both have security issues. Actually the latter also is true of mbedtls/polarssl.

2: Only TLS 1.2 is supported. This makes multiple clients unable to connect.

BTW, I got this working after modifying the Makefile to luci-ssl to depend on libustream-openssl instead. No idea what the situation is but so far it works without a problem.

neheb commented on 07.09.2016 04:17

Can't find an edit button....

I'll add a third.

Elliptic Curve support is enabled in the config but it does not seem to be exposed in luci-ssl.

Avi H. D. commented on 24.11.2016 22:08

Yep, building Elliptic Curve support on x86/64 fails for me.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing