Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1590 - adsl bug with nic-nas0 #7957

Closed
openwrt-bot opened this issue Jun 16, 2018 · 1 comment
Closed

FS#1590 - adsl bug with nic-nas0 #7957

openwrt-bot opened this issue Jun 16, 2018 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

Pionegr:

Hi!
I have device Netgear DGN3500 with firmware
LEDE Reboot 17.01-SNAPSHOT r3896-6eec0e46ed / LuCI lede-17.01 branch (git-18.143.19815-d585fd7)
Custom, with luci, openvpn,wireguard etc.

Configuration:

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdab:469b:8ee8::/48'

config atm-bridge 'atm'
option vpi '0'
option vci '33'
option encaps 'llc'
option payload 'routed'

config dsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/adsl.bin'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'nas0'
option proto 'pppoe'
option username 'myuser'
option password 'mypassword'
option ipv6 '1'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

Interfaces:
root@LEDE:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UNKNOWN group default qlen 1000
link/ether 00:11:22:33:44:55 brd ff:ff:ff:ff:ff:ff
inet6 fe80::211:22ff:fe33:4455/64 scope link
valid_lft forever preferred_lft forever
3: sit0@NONE: mtu 1480 qdisc noop state DOWN group default qlen 1
link/sit 0.0.0.0 brd 0.0.0.0
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether e0:46:9a:ae:f0:d7 brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:11:22:33:44:55 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
valid_lft forever preferred_lft forever
inet6 fdab:469b:8ee8::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::211:22ff:fe33:4455/64 scope link
valid_lft forever preferred_lft forever
6: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
link/ether 00:11:22:33:44:55 brd ff:ff:ff:ff:ff:ff
7: nas0: <POINTOPOINT,MULTICAST,NOARP> mtu 1500 qdisc fq_codel state DOWN group default qlen 100
link/ppp

DSL status:

root@LEDE:~# /etc/init.d/dsl_control status
ATU-C Vendor ID: Broadcom 98.145
ATU-C System Vendor ID: 00,00,00,00,00,00,00,00
Chipset: Ifx-AR9 1.2
Firmware Version: 4.4.4.0.0.1
API Version: 3.24.4.4
XTSE Capabilities: 0x4, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0
Annex: A
Line Mode: G.992.1 (ADSL)
Profile:
Line State: UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS): Near: 0 / Far: 0
Errored seconds (ES): Near: 0 / Far: 0
Severely Errored Seconds (SES): Near: 0 / Far: 0
Loss of Signal Seconds (LOSS): Near: 0 / Far: 0
Unavailable Seconds (UAS): Near: 22 / Far: 22
Header Error Code Errors (HEC): Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P): Near: / Far:
Pre-emtive CRC errors (CRCP_P): Near: / Far:
Power Management Mode: L0 - Synchronized
Latency / Interleave Delay: Down: Interleave (8.0 ms) / Up: Interleave (8.0 ms)
Data Rate: Down: 6.144 Mb/s / Up: 1.024 Mb/s
Line Attenuation (LATN): Down: 13.6dB / Up: 9.0dB
Signal Attenuation (SATN): Down: 15.5dB / Up: 9.0dB
Noise Margin (SNR): Down: 26.2dB / Up: 13.0dB
Aggregate Transmit Power (ACTATP): Down: 19.6dB / Up: 12.2dB
Max. Attainable Data Rate (ATTNDR): Down: 10.416 Mb/s / Up: 1.200 Mb/s
Line Uptime Seconds: 44
Line Uptime: 44s

When i connect to wan
ifup wan
i have error in log

Fri May 25 04:22:43 2018 kern.err kernel: [ 9629.170138] [DSL_BSP_Showtime 894]: Datarate US intl = 1024000, fast = 0
Fri May 25 04:22:43 2018 kern.warn kernel: [ 9629.175501] enter showtime, cell rate: 0 - 2415, 1 - 2415, xdata addr: 0x82f30000
Fri May 25 04:22:43 2018 kern.info kernel: [ 9629.183136] IPv6: ADDRCONF(NETDEV_CHANGE): nas0: link becomes ready
Fri May 25 04:22:43 2018 daemon.notice netifd: Network device 'nas0' link is up
Fri May 25 04:22:43 2018 daemon.notice netifd: Interface 'wan' has link connectivity
Fri May 25 04:22:43 2018 daemon.notice netifd: Interface 'wan' is setting up now
Fri May 25 04:22:43 2018 daemon.info pppd[4608]: Plugin rp-pppoe.so loaded.
Fri May 25 04:22:43 2018 daemon.info pppd[4608]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): /usr/sbin/pppd: unrecognized option 'nic-nas0'
Fri May 25 04:22:43 2018 daemon.err pppd[4608]: unrecognized option 'nic-nas0'
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): pppd version 2.4.7
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): Usage: /usr/sbin/pppd [ options ], where options are:
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): Communicate over the named device
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): Set the baud rate to
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): : Set the local and/or remote interface IP
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): addresses. Either one may be omitted.
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): asyncmap Set the desired async map to hex
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): auth Require authentication from peer
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): connect

Invoke shell command

to set up the serial line
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): crtscts Use hardware RTS/CTS flow control
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): defaultroute Add default route through interface
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): file Take options from file
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): modem Use modem control lines
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): mru Set MRU value to for negotiation
Fri May 25 04:22:43 2018 daemon.notice netifd: wan (4608): See pppd(8) for more options.
Fri May 25 04:22:44 2018 daemon.notice netifd: Interface 'wan' is now down
Fri May 25 04:22:44 2018 daemon.notice netifd: Interface 'wan' is disabled
Fri May 25 04:22:44 2018 daemon.notice netifd: Network device 'nas0' link is down
Fri May 25 04:22:44 2018 daemon.notice netifd: Interface 'wan' has link connectivity loss

What is "unrecognized option 'nic-nas0'"
Can you help me? Thx

@openwrt-bot
Copy link
Author

None:

I regard the 'option payload 'routed'' to be unusual - it's unusual to send PPPoE over a routed llc atm vc. Maybe it is correct but I'd expect 'option payload 'bridged'' as the more common configuration.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant