OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Mirko Parthey - 05.06.2018
Last edited by Jo-Philipp Wich - 30.07.2018

FS#1576 - Regression: device model reported as "unknown"

Tree

18.06 and trunk

Device

  • tested on Asus WL500W (brcm47xx)
  • other devices may be affected

Problem description

The device model is now reported as “unknown”, while LEDE 17.01 still showed “Asus WL500W”.

Steps to reproduce

  • in LuCI, navigate to the start page (Status→Overview), or
  • in the shell, execute
    ubus call system board

The problem was introduced with

commit 78cf5eed6edaa38561e9c9c3ff14a36c1eedfadd
Author:     Mathias Kresin <dev@kresin.me>
AuthorDate: Fri Apr 7 18:01:17 2017 +0200

    treewide: do board detection during preinit
Closed by  Jo-Philipp Wich
30.07.2018 09:25
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with https://g it.openwrt.org/?p=openwrt/openwrt.git;a= commitdiff;h=d7d10f2c1e8511fe07c9760e85f 2272a85168f8d and https://g it.openwrt.org/?p=openwrt/openwrt.git;a= commitdiff;h=c8e8ff1c9fbf699d04e2dc9e01d 3349878ef7883

arrmo commented on 30.07.2018 00:11

FYI, this also occurs for the WNDR3700 v3.

Thanks!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing