OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Jo-Philipp Wich
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
    • Adi (02.10.2016)
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Github Issues - 04.09.2016
Last edited by Yousong Zhou - 22.04.2017

FS#155 - nslookup: can't resolve

Github issue #123 reported by: https://github.com/davidc502

Issue shows itself from command line or LuCi Diagnostics page. Flashed back to stock, and then back to lede to be sure it wasn’t a configuration issue I caused.

root@lede:~# nslookup dev.openwrt.org
nslookup: can't resolve '(null)': Name does not resolve

Name: dev.openwrt.org
Address 1: 217.115.15.26 dev.openwrt.nanl.de
Address 2: 2a00:1328:e000:452::26

However running the following command will work.

root@lede:~# nslookup dev.openwrt.org localhost <<< Added localhost for local lookup.
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

Name: dev.openwrt.org
Address 1: 217.115.15.26 dev.openwrt.nanl.de
Address 2: 2a00:1328:e000:452::26

This issue appears to affect Dynamic DNS.

Closed by  Yousong Zhou
22.04.2017 02:22
Reason for closing:  Fixed
Additional comments about closing:  

Fixed by jow with a new busybox nslookup applet.

Github Issues commented on 04.09.2016 17:49

davidc502 commented on Jun 15 • edited
For those who need a work around.This also temporarily fixes Dynamic DNS which depends on nslookup.

Remove the symbolic link nslookup in /usr/bin

Put the following command in a script, NAME IT nslookup and place it in /usr/bin
Don't forget to make it executable.

/bin/busybox nslookup $1 localhost

name server lookups work properly
.
root@lede:~# nslookup google.com
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

Name: google.com
Address 1: 74.125.196.102 yk-in-f102.1e100.net
Address 2: 74.125.196.113 yk-in-f113.1e100.net
Address 3: 74.125.196.100 yk-in-f100.1e100.net
Address 4: 74.125.196.138 yk-in-f138.1e100.net
Address 5: 74.125.196.139 yk-in-f139.1e100.net
Address 6: 74.125.196.101 yk-in-f101.1e100.net
Address 7: 2607:f8b0:4002:c07::65 yk-in-x65.1e100.net
   

hnyman commented on Jun 21
This sounds like the musl - busybox nslookup incompatibility (regarding the server parameter, both using it and displaying it).

https://dev.openwrt.org/ticket/18333
https://dev.openwrt.org/ticket/20893

   

davidc502 commented on Jul 16
Just compiled lede r1003 and the issue is still there. Does anyone know if it is being looked at?

Arjen de Korte commented on 05.09.2016 12:29

The workaround proposed above does not solve the underlying issue. The tickets above explain this is a fundamental problem with busybox using the musl library.

Admin
Jo-Philipp Wich commented on 14.03.2017 22:22

Please try the latest commit in my staging tree: https://git.lede-project.org/b4bfa07

If you customized your busybox settings, you need to deselect the "nslookup" applet and select the appearing "nslookup_lede" variant instead. If you did not customize the busybox config, the applet should get replaced automatically.

Admin
Jo-Philipp Wich commented on 14.03.2017 22:29

Size comparison between nslookup and nslookup_lede:

busybox w/ nslookup

-rw-r--r-- 1 jow jow 215K Mar 14 22:47 bin/packages/x86_64/base/busybox_1.26.2-2_x86_64.ipk
-rwxr-xr-x 1 jow jow 423K Mar 14 22:47 build_dir/target-x86_64_musl/busybox-1.26.2/busybox_unstripped
-rwxr-xr-x 1 jow jow 347K Mar 14 22:47 build_dir/target-x86_64_musl/busybox-1.26.2/ipkg-x86_64/busybox/bin/busybox

busybox w/ nslookup_lede

-rw-r--r-- 1 jow jow 219K Mar 14 22:43 bin/packages/x86_64/base/busybox_1.26.2-2_x86_64.ipk
-rwxr-xr-x 1 jow jow 432K Mar 14 22:43 build_dir/target-x86_64_musl/busybox-1.26.2/busybox_unstripped
-rwxr-xr-x 1 jow jow 355K Mar 14 22:43 build_dir/target-x86_64_musl/busybox-1.26.2/ipkg-x86_64/busybox/bin/busybox
Val Kulkov commented on 29.05.2017 03:46

Please ignore my request to reopen. I am not yet completely familiar with the Flyspray interface; noticed the comments here (far below in the page) after my request had already been submitted. I am confirming that when nslookup_lede option is selected, nslookup works fine. Perhaps there should be only one option for the nslookup applet – the one that works properly.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing