OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Hans Dedecker
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Brian J. Murrell - 26.03.2018
Last edited by Hans Dedecker - 18.04.2018

FS#1457 - odhcpd annoucing dhcpv6 even when it's not enabled

Supply the following if possible:
- Device problem occurs on
wndr4300
- Software versions of OpenWrt/LEDE release, packages, etc.
17.01.4, r3560-79f57e422d
odhcpd - 2018-03-02-2da5850f-3
- Steps to reproduce
/etc/config/dhcp snippet:

  config dhcp 'lan'
      option interface 'lan'
      option dhcpv6 'disabled'
      option ra 'server'
      option ra_management '1'
      list dns 'fd31:aeb1:48df::2'

Notice that “option dhcpv6 ‘disabled’” yet neighbour discovery is still saying DHCPv6 is available:

$ sudo rdisc6 eth0
Soliciting ff02::2 (ff02::2) on eth0...

Hop limit                 :           64 (      0x40)
Stateful address conf.    :          Yes
...
Closed by  Hans Dedecker
18.04.2018 12:28
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in commit https://git.op enwrt.org/?p=project/odhcpd.git;a=commit ;h=dcfc06a7cf32e21ae575ea491ba0206844596 516

01.01.2019 : A request to re-open the task has been made. Reason for request: Issue reported is should be the behaviour of odhcpd when configured in this way. This is necessary to support DHCPv6 servers running elsewhere on the network.
Brian J. Murrell commented on 26.05.2018 19:09

How do we get this backported to current openwrt/lede?

Project Manager
Hans Dedecker commented on 27.05.2018 07:32

This is already in current OpenWRT/Lede master as the hash points to 413652910234f44e11d6550abf6871621474b8cb (https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=package/network/services/odhcpd/Makefile;h=f78fb9485bd599a26e7a0d180a62c41b53e1853d;hb=HEAD#l17) which includes the relevant fix

Brian J. Murrell commented on 27.05.2018 11:05

But master is not where updates to current (i.e. 17.01) OpenWRT/Lede come from is it? Isn't that lede-17.01?

Brian J. Murrell commented on 27.05.2018 12:07

I created a PR FWIW.

Project Manager
Hans Dedecker commented on 27.05.2018 19:46

The patch was not backported to lede-17.01 branch as it was not seen as a critical show stopper for lede-17.01 neither was it requested to be backported.
I can backport the patch to lede-17.01 so it will be included in the 17.01.05 release which is in the pipeline

Adam Turner commented on 29.12.2018 15:18

The behaviour reported in this issue should be the intended (and documented) behaviour of odhcpd. From the documentation here:

ra_management	integer	1			RA management mode
		                                0: no M-Flag but A-Flag
                                                1: both M and A 
                                                2: M but not A

option ra_management '1' will set both the M and the A flags in a RA. This will indicate to a client that both stateless and stateful (DHCPv6) configuration is available.

To prevent the router showing DHCPv6 as available (M flag), one should set option ra_management '0'

The fix to this issue results in the M flag not being able to be set whilst the DHCPv6 server is disabled. This prevents the use of DHCPv6 servers elsewhere on the network allowing for centralised IP allocation management – a main use case for DHCPv6.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing