OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Othmar Truniger - 24.03.2018

FS#1454 - argp-standalone: option ARGP_NO_ERRS is not honoured

Symptom: error message is written for invalid option even with ARGP_NO_ERRS set in function argp_parse

 

Verified on ar71xx / mips_24kc / wndr3700 and mpc85xx / powerpc_8540 / tl-wdr4900
OpenWrt / LEDE trunk OpenWrt SNAPSHOT, r6548-8e1065d681

Found a problem when working with a software project where the LEDE / OpenWrt binary issues an error message for an invalid option when starting the binary while the debian / ubuntu linux version does not. I tracked it down to the fact that it must be a bug in the argp-standalone library of OpenWrt / LEDE where the option ARGP_NO_ERRS in function argp_parse is not honoured.

To reproduce I wrote a little demo program which works fine on debian and ubuntu but shows the invalid behaviour on OpenWrt / LEDE.

The demo program is hosted on https://github.com/tru7/argp-demo where I have also provided a feed named Makefile.lede to build the package on OpenWrt / LEDE.

I have no skills in coding and absolutely no skills in debugging, so this is about all I can do about this.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing