Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1379 - IPv6 DNS setting Problem #6440

Closed
openwrt-bot opened this issue Feb 21, 2018 · 1 comment
Closed

FS#1379 - IPv6 DNS setting Problem #6440

openwrt-bot opened this issue Feb 21, 2018 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

PaTTeeL:

Software versions : Linux version 4.9.82 (buildbot@slashdirt-02) (gcc version 5.5.0 (OpenWrt GCC 5.5.0 r6194-138c763) ) #0 Mon Feb 19 22:54:38 2018
Device : WZR HP G300NH2 and PHICOMM K3

BUG : Can't set IPv6's DNS to Customized Server

I've set the IPv6 DNS to "2001:4860:4860::8888", but in Status->Overview , "IPv6 WAN Status" still shows
"pppoe-wan Type: dhcpv6-pd
Prefix Delegated: 240e:f2:xxxx:xxxx::/60
Address: 240e:f2:c01c:a9e:xxxx:xxxx:xxxx:xxxx/64
Gateway: fe80::e224:xxxx:xxxx:772
DNS 1: 240e:1c:200::1
DNS 2: 240e:1c:200::2
Connected: 11h 55m 17s"

cat /etc/config/network :
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '64'
option dns '8.8.8.8 8.8.4.4'

config interface 'wan'
option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'pppoe'
option username 'xxxxxxxx'
option password 'xxxxxxxx'
option ipv6 'auto'
option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option peerdns '0'
option dns '2001:4860:4860::8888 2001:4860:4860::8844'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 3 4 5 0t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '2 0t'

Here's IPv4 WAN Status :

pppoe-wan Type: pppoe
Address: 122.232.xxx.xxx
Netmask: 255.255.255.255
Gateway: 122.232.xxx.xxx
DNS 1: 8.8.8.8
DNS 2: 8.8.4.4
DNS 3: 220.189.127.106
DNS 4: 220.189.127.107
Connected: 11h 58m 29s

cat /etc/config/dhcp shows:
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option ra 'hybrid'
option dhcpv6 'hybrid'
option ra_management '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

@openwrt-bot
Copy link
Author

dedeckeh:

The config needs to be changed as follows :

config interface 'wan'
option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'pppoe'
option username 'xxxxxxxx'
option password 'xxxxxxxx'
option ipv6 '1'
option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option peerdns '0'
option dns '2001:4860:4860::8888 2001:4860:4860::8844'

Setting ipv6 to auto creates an auto wan6 interface which is not using the configured IPv6 DNS servers; the above adapted config should fix that

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant