OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Edward Arreza - 25.01.2018

FS#1300 - RT-N12+(MT7620N): WLAN not working.

Hello,

Device: RT-N12+
Issue: WLAN is not working properly. When enabled the signal status shows 0db noise 0db. Wireless devices would properly show the SSID however unable to join. Even with No encryption. The system log would even show that radio0 is up.
Steps done:
- Reboot Router
- Re-flash firmware
- Manually set WiFi config: Band 20mhz or 40mhz.
- Toggled between N and Legacy.
- Manually set WiFi channels.
- Tried different encryption.

Additional information:
- I am well aware that this router support is still WIP as stated: https://lede-project.org/toh/hwdata/asus/asus_rt-n12 Basically just putting out this bug report since so far everything seemed fine except for wireless broadcast.
- Used latest snapshot build from downloads page dated: Thu Jan 25 12:07:37 2018

markuznw commented on 25.01.2018 20:07

Confirmed on my Mi Router 3G (MT7621A), wifi dead for me as well after 99eb128acaf76a69119fd2de8e194f2b2bbb0427
SSID are showing, smartphones are even connecting but shows "!" or simply unable to open any web page :(

Edward Arreza commented on 26.01.2018 16:23

Just to add some logs that might be helpful.
Updated to latest snapshot build - OpenWrt SNAPSHOT, r5952-cfdfa6d

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT40'
        option channel '6'
        option legacy_rates '0'
        option country 'PH'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wmm '1'
        option ssid 'EATEST'
        option encryption 'psk-mixed+ccmp'
        option key '1234512345'

iwinfo:

wlan0     ESSID: "EATEST"
          Access Point: 9C:5C:8E:44:3A:8C
          Mode: Master  Channel: 6 (2.437 GHz)
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: mixed WPA/WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

iwinfo (without encryption):

wlan0     ESSID: "EATEST"
          Access Point: 9C:5C:8E:44:3A:8C
          Mode: Master  Channel: 6 (2.437 GHz)
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: none
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

dmesg | grep wlan0

[  837.672556] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  837.679383] br-lan: port 2(wlan0) entered blocking state
[  837.684905] br-lan: port 2(wlan0) entered forwarding state
[  875.136117] device wlan0 left promiscuous mode
[  875.141014] br-lan: port 2(wlan0) entered disabled state
[  878.733584] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  878.781598] br-lan: port 2(wlan0) entered blocking state
[  878.787543] br-lan: port 2(wlan0) entered disabled state
[  878.793593] device wlan0 entered promiscuous mode
[  880.940783] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  880.947746] br-lan: port 2(wlan0) entered blocking state
[  880.953242] br-lan: port 2(wlan0) entered forwarding state
[ 1472.118369] device wlan0 left promiscuous mode
[ 1472.123122] br-lan: port 2(wlan0) entered disabled state
[ 1478.604068] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1478.701330] br-lan: port 2(wlan0) entered blocking state
[ 1478.706802] br-lan: port 2(wlan0) entered disabled state
[ 1478.712987] device wlan0 entered promiscuous mode
[ 1480.341058] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1480.347940] br-lan: port 2(wlan0) entered blocking state
[ 1480.353359] br-lan: port 2(wlan0) entered forwarding state
[ 1532.205961] device wlan0 left promiscuous mode
[ 1532.210773] br-lan: port 2(wlan0) entered disabled state
[ 1536.299620] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1536.350182] br-lan: port 2(wlan0) entered blocking state
[ 1536.355765] br-lan: port 2(wlan0) entered disabled state
[ 1536.361814] device wlan0 entered promiscuous mode
[ 1538.705833] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1538.712779] br-lan: port 2(wlan0) entered blocking state
[ 1538.718274] br-lan: port 2(wlan0) entered forwarding state

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing