Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1287 - ipv6 relay issue of odhcpd #6264

Closed
openwrt-bot opened this issue Jan 22, 2018 · 1 comment
Closed

FS#1287 - ipv6 relay issue of odhcpd #6264

openwrt-bot opened this issue Jan 22, 2018 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

isler:

Supply the following if possible:

  • Device problem occurs on Intel(R) Pentium(R) CPU N3700 @ 1.60GHz
  • Software versions of LEDE 17.01.04, odhcpd 2017-10-02-c6f3d5d4-2.
  • Steps to reproduce

i have native ipv6, and i use odhcpd's ipv6 relay (x86 router with lede 17.01.x). It worked well for me, but since the last 2 update of odhcpd, after i reboot the router, the ipv6 link of all devices are broken unless i restart odhcpd (the ipv6 link of the router is ok and all devices can obtain ipv6 addresses from the upper switch before i restart odhcpd).

cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ifname 'eth1 eth2'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option ipaddr '192.168.11.1'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0'
option _orig_ifname 'eth1'
option _orig_bridge 'false'

config interface 'wan6'
option proto 'dhcpv6'
option ifname 'eth0'
option _orig_ifname 'eth1'
option _orig_bridge 'false'

cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
option enable_tftp '1'
option tftp_root '/ssd/pxe'
option dhcp_boot 'lpxelinux.0'
option rebind_protection '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option ra_management '1'
option ra 'hybrid'
option dhcpv6 'hybrid'
option ndp 'hybrid'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

config dhcp 'wan6'
option interface 'wan'
option dhcpv6 'hybrid'
option ra 'hybrid'
option ndp 'hybrid'
option master '1'

@openwrt-bot
Copy link
Author

dedeckeh:

The latest two updates of odhcpd ([[https://git.openwrt.org/?p=project/odhcpd.git;a=commit;h=336212cf315374ded98cd3865ea5927e783b6780]] and [[https://git.openwrt.org/?p=project/odhcpd.git;a=commit;h=c6f3d5d4ea5154e5971fa0b1b1e9a9c07119429f]]) in lede-17.01 branch did not change any IPv6 relay functionality.

The dhcp config you're using can cause problems as you're having a network wan and wan6 interface.
Therefore you should enable the hybrid/relay mode for both the wan and wan6 interfaces as workaround (this limitation is fixed in master):

config dhcp 'wan6' option interface 'wan6' option dhcpv6 'hybrid' option ra 'hybrid' option ndp 'hybrid' option master '1'

config dhcp 'wan'
option interface 'wan'
option dhcpv6 'hybrid'
option ra 'hybrid'
option ndp 'hybrid'
option master '1'
option ignore '1'

Any reason why you're using hybrid and not relay ?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant