OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by bouwew - 14.01.2018
Last edited by Ted Hess - 14.01.2018

FS#1275 - R7800: build error in drivers/clk/qcom - kernel 4.9.76

R7800: fail during make, kernel 4.9.76, fresh git pull, latest commit is named ‘ar71xx: create new ar71xx/tiny subtarget for 4MB flash devicesĀ“.

I wanted to report the error I am encountering.

make[5]: Entering directory '/home/bouwew/LEDE_N/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/linux-4.9.76'
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     include/generated/bounds.h
  CHK     include/generated/timeconst.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CC      drivers/clk/qcom/gdsc.o
drivers/clk/qcom/gdsc.c: In function 'gdsc_init':
drivers/clk/qcom/gdsc.c:358:27: error: 'simple_qos_governor' undeclared (first use in this function); did you mean 'simple_positive'?
   pm_genpd_init(&sc->pd, &simple_qos_governor, !on);
                           ^~~~~~~~~~~~~~~~~~~
                           simple_positive
drivers/clk/qcom/gdsc.c:358:27: note: each undeclared identifier is reported only once for each function it appears in
scripts/Makefile.build:293: recipe for target 'drivers/clk/qcom/gdsc.o' failed
make[8]: *** [drivers/clk/qcom/gdsc.o] Error 1
scripts/Makefile.build:544: recipe for target 'drivers/clk/qcom' failed
make[7]: *** [drivers/clk/qcom] Error 2
scripts/Makefile.build:544: recipe for target 'drivers/clk' failed
make[6]: *** [drivers/clk] Error 2
Makefile:995: recipe for target 'drivers' failed
make[5]: *** [drivers] Error 2
make[5]: Leaving directory '/home/bouwew/LEDE_N/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/linux-4.9.76'
Makefile:26: recipe for target '/home/bouwew/LEDE_N/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/linux-4.9.76/.image' failed
make[4]: *** [/home/bouwew/LEDE_N/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x/linux-4.9.76/.image] Error 2
make[4]: Leaving directory '/home/bouwew/LEDE_N/target/linux/ipq806x'
Makefile:13: recipe for target 'install' failed
make[3]: *** [install] Error 2
make[3]: Leaving directory '/home/bouwew/LEDE_N/target/linux'
target/Makefile:23: recipe for target 'target/linux/install' failed
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory '/home/bouwew/LEDE_N'
target/Makefile:19: recipe for target '/home/bouwew/LEDE_N/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.target_install' failed
make[1]: *** [/home/bouwew/LEDE_N/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.target_install] Error 2
make[1]: Leaving directory '/home/bouwew/LEDE_N'
/home/bouwew/LEDE_N/include/toplevel.mk:216: recipe for target 'world' failed
 


Closed by  Ted Hess
14.01.2018 20:24
Reason for closing:  Not a bug

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing