OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Some M. Stuff - 10.01.2018
Last edited by Mathias Kresin - 27.02.2018

FS#1265 - dnsmasq-full breaks dnsmasq on install

Apologize in advance if Critical is not the correct severity for a package needed to make dnssec work.

I’ve used dnssec mostly successfully with dnscrypt-proxy & dnsmasq-full on Choas Calmer. I recently upgraded to LEDE & the dnsmasq-full package fails to start dnsmasq for some reason. Apparently I need the dnsmasq-full package to use dnssec.

At any rate, there is a new dnsmasq error message (vice Choas Calmer) on init.d restart with both the base & full package, so I’m not sure if it’s relevant:
udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: no lease, failing

I’ve tried resetting to the default dhcp & checked that dnsmasq.conf is basically still empty - to no avail.

What might I be doing wrong?

Supply the following if possible:
- Steps to reproduce
1. Update to LEDE 7.01.4 (sysupgrade)
2. Install all upgradable packages
3. Install dnsmasq-full – dnsmasq fails to load

- Device problem occurs on: WNDR3700v4

- Software versions of:

  1. - LEDE release (LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.336.23170-d2dc32a))
  2. - packages:

base-files - 173.1-r3560-79f57e422d
busybox - 1.25.1-4
dnscrypt-proxy - 1.9.4-1
dnscrypt-proxy-resolvers - 1.9.4+git-20161129-f17bace-1
dnsmasq - 2.78-4
dropbear - 2017.75-4
firewall - 2017-05-27-a4d98aea-1
fstools - 2017-06-30-bdcb075f-1
fwtool - 1
hostapd-common - 2016-12-19-ad02e79d-7
ip6tables - 1.4.21-2
iptables - 1.4.21-2
iw - 4.9-1
iwinfo - 2016-09-21-fd9e17be-1
jshn - 2018-01-07-1dafcd78-1
jsonfilter - 2016-07-02-dea067ad-1
kernel - 4.4.92-1-7163756290c10ef7734df504f3a8958b
kmod-ath - 4.4.92+2017-01-31-3
kmod-ath9k - 4.4.92+2017-01-31-3
kmod-ath9k-common - 4.4.92+2017-01-31-3
kmod-cfg80211 - 4.4.92+2017-01-31-3
kmod-gpio-button-hotplug - 4.4.92-2
kmod-ip6tables - 4.4.92-1
kmod-ipt-conntrack - 4.4.92-1
kmod-ipt-core - 4.4.92-1
kmod-ipt-nat - 4.4.92-1
kmod-leds-wndr3700-usb - 4.4.92-1
kmod-lib-crc-ccitt - 4.4.92-1
kmod-mac80211 - 4.4.92+2017-01-31-3
kmod-nf-conntrack - 4.4.92-1
kmod-nf-conntrack6 - 4.4.92-1
kmod-nf-ipt - 4.4.92-1
kmod-nf-ipt6 - 4.4.92-1
kmod-nf-nat - 4.4.92-1
kmod-nls-base - 4.4.92-1
kmod-ppp - 4.4.92-1
kmod-pppoe - 4.4.92-1
kmod-pppox - 4.4.92-1
kmod-slhc - 4.4.92-1
kmod-usb-core - 4.4.92-1
kmod-usb-ledtrig-usbport - 4.4.92-1
kmod-usb-ohci - 4.4.92-1
kmod-usb-printer - 4.4.92-1
kmod-usb2 - 4.4.92-1
lede-keyring - 2017-01-20-a50b7529-1
libblobmsg-json - 2018-01-07-1dafcd78-1
libc - 1.1.16-1
libgcc - 5.4.0-1
libip4tc - 1.4.21-2
libip6tc - 1.4.21-2
libiwinfo - 2016-09-21-fd9e17be-1
libiwinfo-lua - 2016-09-21-fd9e17be-1
libjson-c - 0.12.1-1
libjson-script - 2018-01-07-1dafcd78-1
liblua - 5.1.5-1
libnl-tiny - 0.1-5
libpthread - 1.1.16-1
libsodium - 1.0.11-2
libubox - 2018-01-07-1dafcd78-1
libubus - 2017-02-18-34c6e818-1
libubus-lua - 2017-02-18-34c6e818-1
libuci - 2018-01-01-141b64ef-1
libuci-lua - 2018-01-01-141b64ef-1
libuclient - 2017-11-02-4b87d831-1
libxtables - 1.4.21-2
logd - 2017-03-10-16f7e161-1
lua - 5.1.5-1
luci - git-18.007.32064-ff21f2f-1
luci-app-firewall - git-18.007.32064-ff21f2f-1
luci-app-p910nd - git-18.007.32064-ff21f2f-1
luci-base - git-18.007.32064-ff21f2f-1
luci-lib-ip - git-18.007.32064-ff21f2f-1
luci-lib-jsonc - git-18.007.32064-ff21f2f-1
luci-lib-nixio - git-18.007.32064-ff21f2f-1
luci-mod-admin-full - git-18.007.32064-ff21f2f-1
luci-proto-ipv6 - git-18.007.32064-ff21f2f-1
luci-proto-ppp - git-18.007.32064-ff21f2f-1
luci-theme-bootstrap - git-18.007.32064-ff21f2f-1
mtd - 21
netifd - 2017-01-25-650758b1-1
odhcp6c - 2017-01-30-c13b6a05-2
odhcpd - 2017-10-02-c6f3d5d4-2
openssh-sftp-server - 7.4p1-1
opkg - 2017-03-23-1d0263bb-1
p910nd - 0.97-5
ppp - 2.4.7-12
ppp-mod-pppoe - 2.4.7-12
procd - 2017-08-08-66be6a23-1
procd-nand - 2017-08-08-66be6a23-1
rpcd - 2017-12-07-cfe1e75c-1
swconfig - 11
ubi-utils - 1.5.2-1
uboot-envtools - 2015.10-1
ubox - 2017-03-10-16f7e161-1
ubus - 2017-02-18-34c6e818-1
ubusd - 2017-02-18-34c6e818-1
uci - 2018-01-01-141b64ef-1
uclient-fetch - 2017-11-02-4b87d831-1
uhttpd - 2017-11-04-a235636a-1
uhttpd-mod-ubus - 2017-11-04-a235636a-1
usign - 2015-07-04-ef641914-1
wpad-mini - 2016-12-19-ad02e79d-7

Closed by  Mathias Kresin
27.02.2018 16:18
Reason for closing:  No response
Admin
Jo-Philipp Wich commented on 10.01.2018 17:24

Can you summarize what the actual problem is? DNSSEC resolving not working?

The udhcpc messages are normal, this is just the dnsmasq init script checking downstream interfaces for other active DHCP servers in the segment to avoid acting as rogue server.

Did you check "logread" for errors? Was the time correct?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing