OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by kevin-fibich - 08.01.2018
Last edited by Mathias Kresin - 10.01.2018

FS#1264 - Kernel Panic during boot on Aerohive Hiveap 121

- Device problem occurs on:

Aerohive HiveAP 121

- Software versions of LEDE release:

Development Snapshot ar71xx/nand/hiveap-121-squashfs-factory.bin 07.01.2018, 08.01.2018

- Steps to reproduce:

 

Connect HiveAP to console, halt uboot via spacebar, enter password “administrator”:

dhcp
setenv serverip #tftpserver#
tftpboot 0×81000000 /openwrt-ar71xx-nand-hiveap-121-squashfs-factory.bin
bootm

System Bootlog:

[ 0.000000] Linux version 4.9.73 (buildbot@slashdirt-02) (gcc version 5.5.0 (OpenWrt GCC 5.5.0 r5693-f1fb710) ) #0 Sun Jan 7 22:42:54 2018
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9344 rev 2
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] OF: fdt:No valid device tree found, continuing without
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0×0000000000000000-0x0000000007ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0×0000000000000000-0x0000000007ffffff]
[ 0.000000] Initmem setup node 0 [mem 0×0000000000000000-0x0000000007ffffff]
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512
[ 0.000000] Kernel command line: board=HiveAP-121 mtdparts=spi0.0:512k(u-boot)ro,64k(u-boot-env),64k(hw-info)ro,64k(boot-info)ro,64k(boot-sinfo)ro;ar934x-nfc:4096k(u-boot-1),4096k(u-boot-env-1),5m(kernel),111m(ubi),4096k(wifi-info)ro console=ttyS0,9600 rootfstype=squashfs noinitrd
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 124292K/131072K available (3737K kernel code, 158K rwdata, 884K rodata, 204K init, 218K bss, 6780K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:51
[ 0.000000] Clocks: CPU:560.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:40.000MHz
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6825930166 ns
[ 0.000009] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669584382ns
[ 0.092723] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
[ 0.237730] pid_max: default: 32768 minimum: 301
[ 0.293075] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.372211] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.459118] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.576715] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.650827] NET: Registered protocol family 16
[ 0.705478] MIPS: machine is Aerohive HiveAP-121
[ 1.005746] registering PCI controller with io_map_base unset
[ 1.089650] i2c-gpio i2c-gpio.0: using pins 13 (SDA) and 12 (SCL)
[ 1.162823] PCI host bridge to bus 0000:00
[ 1.211830] pci_bus 0000:00: root bus resource [mem 0×10000000-0x13ffffff]
[ 1.294067] pci_bus 0000:00: root bus resource [io 0×0000]
[ 1.360731] pci_bus 0000:00: root bus resource [??? 0×00000000 flags 0×0]
[ 1.441955] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[ 1.536750] pci 0000:00:00.0: invalid calibration data
[ 1.598590] pci 0000:00:00.0: BAR 0: assigned [mem 0×10000000-0x1001ffff 64bit]
[ 1.686082] pci 0000:00:00.0: BAR 6: assigned [mem 0×10020000-0x1002ffff pref]
[ 1.772478] pci 0000:00:00.0: using irq 40 for pin 1
[ 1.835062] clocksource: Switched to clocksource MIPS
[ 1.896637] NET: Registered protocol family 2
[ 1.949713] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 2.033042] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 2.109026] TCP: Hash tables configured (established 1024 bind 1024)
[ 2.185134] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 2.254964] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 2.330169] NET: Registered protocol family 1
[ 2.385117] Crashlog allocated RAM at address 0x3f00000
[ 2.448618] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[ 2.533269] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 2.603043] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 2.729119] io scheduler noop registered
[ 2.775999] io scheduler deadline registered (default)
[ 2.837988] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[ 2.916822] console [ttyS0] disabled
[ 2.979603] serial8250.0: ttyS0 at MMIO 0×18020000 (irq = 11, base_baud = 2500000) is a 16550A
[ 3.082659] console [ttyS0] enabled
[ 3.082659] console [ttyS0] enabled
[ 3.165947] bootconsole [early0] disabled
[ 3.165947] bootconsole [early0] disabled
[ 3.267330] m25p80 spi0.0: found mx25l8005, expected m25p80
[ 3.334571] m25p80 spi0.0: mx25l8005 (1024 Kbytes)
[ 3.391901] 5 cmdlinepart partitions found on MTD device spi0.0
[ 3.462659] Creating 5 MTD partitions on “spi0.0”:
[ 3.519969] 0×000000000000-0×000000080000 : “u-boot” [ 3.580852] 0×000000080000-0×000000090000 : “u-boot-env” [ 3.646092] 0×000000090000-0x0000000a0000 : “hw-info” [ 3.708231] 0x0000000a0000-0x0000000b0000 : “boot-info” [ 3.772413] 0x0000000b0000-0x0000000c0000 : “boot-sinfo” [ 3.839116] nand: device found, Manufacturer ID: 0xad, Chip ID: 0xf1
[ 3.915190] nand: Hynix NAND 128MiB 3,3V 8-bit
[ 3.968308] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[ 4.058930] Scanning device for bad blocks
[ 4.108337] Bad eraseblock 5 at 0x0000000a0000
[ 4.164169] random: fast init done
[ 4.241208] Bad eraseblock 484 at 0x000003c80000
[ 4.338291] Bad eraseblock 997 at 0x000007ca0000
[ 4.395613] 5 cmdlinepart partitions found on MTD device ar934x-nfc
[ 4.470526] Creating 5 MTD partitions on “ar934x-nfc”:
[ 4.531994] 0×000000000000-0×000000400000 : “u-boot-1” [ 4.594918] 0×000000400000-0×000000800000 : “u-boot-env-1” [ 4.662281] 0×000000800000-0x000000d00000 : “kernel” [ 4.723396] 0x000000d00000-0x000007c00000 : “ubi” [ 4.781871] 0x000007c00000-0×000008000000 : “wifi-info” [ 4.846848] libphy: Fixed MDIO Bus: probed
[ 4.901961] libphy: ag71xx_mdio: probed
[ 5.675284] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd072, driver=Atheros 8035 ethernet]
[ 5.795715] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[ 5.870290] NET: Registered protocol family 10
[ 5.926971] NET: Registered protocol family 17
[ 5.980182] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[ 6.135368] 8021q: 802.1Q VLAN Support v1.8
[ 6.189115] UBI error: no valid UBI magic found inside mtd8
[ 6.255836] hctosys: unable to open rtc device (rtc0)
[ 6.316609] VFS: Cannot open root device “(null)” or unknown-block(0,0): error -6
[ 6.406207] Please append a correct “root=” boot option; here are the available partitions:
[ 6.506125] 1f00 512 mtdblock0 [ 6.554056] (driver?)
[ 6.582248] 1f01 64 mtdblock1 [ 6.630184] (driver?)
[ 6.658375] 1f02 64 mtdblock2 [ 6.706313] (driver?)
[ 6.734502] 1f03 64 mtdblock3 [ 6.782452] (driver?)
[ 6.810633] 1f04 64 mtdblock4 [ 6.858569] (driver?)
[ 6.886765] 1f05 4096 mtdblock5 [ 6.934695] (driver?)
[ 6.962887] 1f06 4096 mtdblock6 [ 7.010824] (driver?)
[ 7.039015] 1f07 5120 mtdblock7 [ 7.086952] (driver?)
[ 7.115143] 1f08 113664 mtdblock8 [ 7.163080] (driver?)
[ 7.191271] 1f09 4096 mtdblock9 [ 7.239208] (driver?)
[ 7.267398] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 7.367376] Rebooting in 1 seconds..

Closed by  Mathias Kresin
10.01.2018 07:21
Reason for closing:  Not a bug
Project Manager
Christian Lamparter commented on 08.01.2018 19:07
dhcp
setenv serverip #tftpserver#
tftpboot 0×81000000 /openwrt-ar71xx-nand-hiveap-121-squashfs-factory.bin
bootm

Where did you get the flashing instructions from? They look similar to the one in the commit but they lack the flashing the nand step.

dhcp;
setenv serverip tftp-server-ip;
tftpboot 0x81000000 lede-ar71xx-nand-hiveap-121-squashfs-factory.bin;
nand erase 0x800000 0x800000;
nand write 0x81000000 0x800000 0x800000;
reset;

Is this an error on your part?

Project Manager
Mathias Kresin commented on 10.01.2018 07:21

The openwrt-ar71xx-nand-hiveap-121-squashfs-factory.bin can't be booted from RAM, it is meant to be written to flash.

You need to build an initramfs image to do a ram boot.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing