OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Aaron Z - 29.12.2017
Last edited by Yousong Zhou - 26.01.2018

FS#1246 - Ubnt Nanostation Loco M2 - WDS link drops out after a few hours

Ubnt Nanostation Loco M2 - WDS link drops out after a few hours
I have a pair of Nanostation Loco M2 access points setup as a wireless bridge over a ~1300 foot (~400M) line of sight link.
I have had LEDE 17.01.3, 17.0.4 and OpenWrt SNAPSHOT r5499-575178e / LuCI Master (git-17.343.27587-8e6b1a6).

One is setup as a WDS AP and the other is setup as a WDS Client, after a few hours (4-12 hours?) the link drops out but still says that is connected (if I go to status it shows the other AP as connected but I cannot ping or do anything else across the link).
If I restart the wireless service on the client, the connection comes right back and all is well for a 4-12 hours.
Anyone have any suggestions on where to look? Below are the kernel and system logs for the time period in question:

AP Config files:
/etc/config/network:

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr 'x.x.x.2'
	option gateway 'x.x.x.1'
	option dns 'x.x.x.1'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option channel '1'
	option country 'US'
	option htmode 'HT40'
	option distance '400'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LAN_bridge'
	option wds '1'
	option key 'SECRET'
	option encryption 'psk2+tkip+ccmp'

Client Config files:
/etc/config/network:

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr 'x.x.x.3'
	option gateway 'x.x.x.1'
	option dns 'x.x.x.1'
	option _orig_ifname 'eth0'
	option _orig_bridge 'true'
	option ifname 'eth0'
	option delegate '0'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option channel '1'
	option htmode 'HT40'
	option country 'US'
	option distance '400'

config wifi-iface
	option ssid 'LAN_bridge'
	option device 'radio0'
	option mode 'sta'
	option bssid 'AP_BSSID'
	option key 'SECRET'
	option wds '1'
	option network 'lan'
	option encryption 'psk2+tkip+ccmp'

AP Syslog:

Sun Nov 26 14:01:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 14:11:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 14:21:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 14:31:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 14:41:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 14:51:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 15:01:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 15:11:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 15:21:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
**Somewhere in here the link dropped out and I rebooted the client**
Sun Nov 26 15:28:14 2017 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED ClientMAC
Sun Nov 26 15:28:14 2017 kern.info kernel: [1893620.914221] device wlan0.sta1 left promiscuous mode
Sun Nov 26 15:28:14 2017 kern.info kernel: [1893620.919427] br-lan: port 3(wlan0.sta1) entered disabled state
Sun Nov 26 15:28:52 2017 daemon.info hostapd: wlan0: STA ClientMAC IEEE 802.11: authenticated
Sun Nov 26 15:28:52 2017 daemon.info hostapd: wlan0: STA ClientMAC IEEE 802.11: associated (aid 1)
Sun Nov 26 15:28:52 2017 kern.info kernel: [1893659.422460] device wlan0.sta1 entered promiscuous mode
Sun Nov 26 15:28:52 2017 kern.info kernel: [1893659.440920] br-lan: port 3(wlan0.sta1) entered forwarding state
Sun Nov 26 15:28:52 2017 kern.info kernel: [1893659.447086] br-lan: port 3(wlan0.sta1) entered forwarding state
Sun Nov 26 15:28:53 2017 daemon.notice hostapd: wlan0: AP-STA-CONNECTED ClientMAC
Sun Nov 26 15:28:53 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: pairwise key handshake completed (RSN)
Sun Nov 26 15:28:54 2017 kern.info kernel: [1893661.440359] br-lan: port 3(wlan0.sta1) entered forwarding state
Sun Nov 26 15:31:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)
Sun Nov 26 15:41:13 2017 daemon.info hostapd: wlan0: STA ClientMAC WPA: group key handshake completed (RSN)

AP Kernel Log:

[1649563.614654] br-lan: port 1(eth0) entered disabled state
[1649564.612365] eth0: link up (100Mbps/Full duplex)
[1649564.617165] br-lan: port 1(eth0) entered forwarding state
[1649564.622888] br-lan: port 1(eth0) entered forwarding state
[1649566.620738] br-lan: port 1(eth0) entered forwarding state
[1652624.237670] ------------[ cut here ]------------
[1652624.242540] WARNING: CPU: 0 PID: 0 at compat-wireless-2017-01-31/net/mac80211/rx.c:4214 0x80da5cf0 [mac80211@80d80000+0x60780]()
[1652624.254355] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 113 (0x71)
[1652624.264049] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[1652624.328632] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.4.89 #0
[1652624.335791] Stack : 803875b4 00000000 00000001 803e0000 00000000 00000000 00000000 00000000
[1652624.335791] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.335791] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.335791] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.335791] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.335791] 	  ...
[1652624.371919] Call Trace:[<80071a8c>] 0x80071a8c
[1652624.376597] [<80071a8c>] 0x80071a8c
[1652624.380290] [<80081888>] 0x80081888
[1652624.383987] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.390133] [<800818e4>] 0x800818e4
[1652624.393854] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.399981] [<80260a14>] 0x80260a14
[1652624.403663] [<80260bf8>] 0x80260bf8
[1652624.407374] [<80ce8388>] 0x80ce8388 [ath9k_common@80ce8000+0x4800]
[1652624.413800] [<80e677f4>] 0x80e677f4 [ath9k@80e60000+0x16650]
[1652624.419701] [<80e677d4>] 0x80e677d4 [ath9k@80e60000+0x16650]
[1652624.425575] [<80e64a44>] 0x80e64a44 [ath9k@80e60000+0x16650]
[1652624.431446] [<80084448>] 0x80084448
[1652624.435130] [<80083e04>] 0x80083e04
[1652624.438821] [<800a8014>] 0x800a8014
[1652624.442508] [<8006a990>] 0x8006a990
[1652624.446194] [<80060bf4>] 0x80060bf4
[1652624.449876] 
[1652624.451557] ---[ end trace 86b60d5fad42c0e7 ]---
[1652624.456661] ------------[ cut here ]------------
[1652624.461517] WARNING: CPU: 0 PID: 0 at compat-wireless-2017-01-31/net/mac80211/rx.c:4214 0x80da5cf0 [mac80211@80d80000+0x60780]()
[1652624.473297] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 113 (0x71)
[1652624.482988] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[1652624.547552] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.4.89 #0
[1652624.554704] Stack : 803875b4 00000000 00000001 803e0000 00000000 00000000 00000000 00000000
[1652624.554704] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.554704] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.554704] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.554704] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.554704] 	  ...
[1652624.590833] Call Trace:[<80071a8c>] 0x80071a8c
[1652624.595502] [<80071a8c>] 0x80071a8c
[1652624.599197] [<80081888>] 0x80081888
[1652624.602893] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.609038] [<800818e4>] 0x800818e4
[1652624.612760] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.618896] [<80260a14>] 0x80260a14
[1652624.622578] [<80260bf8>] 0x80260bf8
[1652624.626277] [<80ce8388>] 0x80ce8388 [ath9k_common@80ce8000+0x4800]
[1652624.632718] [<80e677f4>] 0x80e677f4 [ath9k@80e60000+0x16650]
[1652624.638615] [<80e677d4>] 0x80e677d4 [ath9k@80e60000+0x16650]
[1652624.644489] [<80e64a44>] 0x80e64a44 [ath9k@80e60000+0x16650]
[1652624.650366] [<80084448>] 0x80084448
[1652624.654046] [<80083e04>] 0x80083e04
[1652624.657738] [<800a8014>] 0x800a8014
[1652624.661423] [<8006a990>] 0x8006a990
[1652624.665109] [<80060bf4>] 0x80060bf4
[1652624.668791] 
[1652624.670471] ---[ end trace 86b60d5fad42c0e8 ]---
[1652624.675578] ------------[ cut here ]------------
[1652624.680433] WARNING: CPU: 0 PID: 0 at compat-wireless-2017-01-31/net/mac80211/rx.c:4214 0x80da5cf0 [mac80211@80d80000+0x60780]()
[1652624.692211] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 113 (0x71)
[1652624.701903] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[1652624.766474] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.4.89 #0
[1652624.773641] Stack : 803875b4 00000000 00000001 803e0000 00000000 00000000 00000000 00000000
[1652624.773641] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.773641] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.773641] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.773641] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.773641] 	  ...
[1652624.809756] Call Trace:[<80071a8c>] 0x80071a8c
[1652624.814426] [<80071a8c>] 0x80071a8c
[1652624.818120] [<80081888>] 0x80081888
[1652624.821816] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.827961] [<800818e4>] 0x800818e4
[1652624.831683] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652624.837810] [<80260a14>] 0x80260a14
[1652624.841493] [<80260bf8>] 0x80260bf8
[1652624.845192] [<80ce8388>] 0x80ce8388 [ath9k_common@80ce8000+0x4800]
[1652624.851632] [<80e677f4>] 0x80e677f4 [ath9k@80e60000+0x16650]
[1652624.857530] [<80e677d4>] 0x80e677d4 [ath9k@80e60000+0x16650]
[1652624.863403] [<80e64a44>] 0x80e64a44 [ath9k@80e60000+0x16650]
[1652624.869275] [<80084448>] 0x80084448
[1652624.872960] [<80083e04>] 0x80083e04
[1652624.876638] [<800a8014>] 0x800a8014
[1652624.880331] [<8006a990>] 0x8006a990
[1652624.884015] [<80060bf4>] 0x80060bf4
[1652624.887697] 
[1652624.889376] ---[ end trace 86b60d5fad42c0e9 ]---
[1652624.894482] ------------[ cut here ]------------
[1652624.899340] WARNING: CPU: 0 PID: 0 at compat-wireless-2017-01-31/net/mac80211/rx.c:4214 0x80da5cf0 [mac80211@80d80000+0x60780]()
[1652624.911125] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 113 (0x71)
[1652624.920817] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables x_tables ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common
[1652624.985380] CPU: 0 PID: 0 Comm: swapper Tainted: G        W       4.4.89 #0
[1652624.992546] Stack : 803875b4 00000000 00000001 803e0000 00000000 00000000 00000000 00000000
[1652624.992546] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.992546] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.992546] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.992546] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[1652624.992546] 	  ...
[1652625.028662] Call Trace:[<80071a8c>] 0x80071a8c
[1652625.033331] [<80071a8c>] 0x80071a8c
[1652625.037027] [<80081888>] 0x80081888
[1652625.040722] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652625.046868] [<800818e4>] 0x800818e4
[1652625.050589] [<80da5cf0>] 0x80da5cf0 [mac80211@80d80000+0x60780]
[1652625.056714] [<80260a14>] 0x80260a14
[1652625.060410] [<80260bf8>] 0x80260bf8
[1652625.064115] [<80ce8388>] 0x80ce8388 [ath9k_common@80ce8000+0x4800]
[1652625.070555] [<80e677f4>] 0x80e677f4 [ath9k@80e60000+0x16650]
[1652625.076442] [<80e677d4>] 0x80e677d4 [ath9k@80e60000+0x16650]
[1652625.082330] [<80e64a44>] 0x80e64a44 [ath9k@80e60000+0x16650]
[1652625.088198] [<80084448>] 0x80084448
[1652625.091882] [<80083e04>] 0x80083e04
[1652625.095561] [<800a8014>] 0x800a8014
[1652625.099258] [<8006a990>] 0x8006a990
[1652625.102938] [<80060bf4>] 0x80060bf4
[1652625.106607] 
[1652625.108295] ---[ end trace 86b60d5fad42c0ea ]---
[1656961.531085] device wlan0.sta1 left promiscuous mode
[1656961.536375] br-lan: port 3(wlan0.sta1) entered disabled state
[1657000.400508] device wlan0.sta1 entered promiscuous mode
[1657000.416849] br-lan: port 3(wlan0.sta1) entered forwarding state
[1657000.423019] br-lan: port 3(wlan0.sta1) entered forwarding state
[1657002.415840] br-lan: port 3(wlan0.sta1) entered forwarding state
[1729152.802304] eth0: link down
[1729152.805769] br-lan: port 1(eth0) entered disabled state
[1729180.803335] eth0: link up (100Mbps/Full duplex)
[1729180.808173] br-lan: port 1(eth0) entered forwarding state
[1729180.813898] br-lan: port 1(eth0) entered forwarding state
[1729182.811672] br-lan: port 1(eth0) entered forwarding state
[1893620.914221] device wlan0.sta1 left promiscuous mode
[1893620.919427] br-lan: port 3(wlan0.sta1) entered disabled state
[1893659.422460] device wlan0.sta1 entered promiscuous mode
[1893659.440920] br-lan: port 3(wlan0.sta1) entered forwarding state
[1893659.447086] br-lan: port 3(wlan0.sta1) entered forwarding state
[1893661.440359] br-lan: port 3(wlan0.sta1) entered forwarding state
[1894771.793057] device wlan0.sta1 left promiscuous mode
[1894771.798391] br-lan: port 3(wlan0.sta1) entered disabled state
[1894777.535302] device wlan0.sta1 entered promiscuous mode
[1894777.547462] br-lan: port 3(wlan0.sta1) entered forwarding state
[1894777.553631] br-lan: port 3(wlan0.sta1) entered forwarding state
[1894779.546485] br-lan: port 3(wlan0.sta1) entered forwarding state
[1895148.287966] device wlan0.sta1 left promiscuous mode
[1895148.293178] br-lan: port 3(wlan0.sta1) entered disabled state
[1895148.349721] device wlan0 left promiscuous mode
[1895148.354492] br-lan: port 2(wlan0) entered disabled state
[1895150.539163] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[1895150.663905] device wlan0 entered promiscuous mode
[1895153.075046] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[1895153.081886] br-lan: port 2(wlan0) entered forwarding state
[1895153.087660] br-lan: port 2(wlan0) entered forwarding state
[1895154.299110] device wlan0.sta1 entered promiscuous mode
[1895154.316512] br-lan: port 3(wlan0.sta1) entered forwarding state
[1895154.322716] br-lan: port 3(wlan0.sta1) entered forwarding state
[1895155.086003] br-lan: port 2(wlan0) entered forwarding state
[1895156.315941] br-lan: port 3(wlan0.sta1) entered forwarding state

Thanks in advance

Aaron Z


Daniel Wandrei commented on 02.01.2018 10:59

I have the same behavior on a TP-LINK WDR3600 ↔ TP-LINK CPE210 setup with WDS. Seems to be something with Atheros chipset. I also have a second WDR3600 and a Ralink WDS client which are rocksolid stable.

Aaron Z commented on 24.01.2018 03:58

Bump, still seeing this in OpenWrt SNAPSHOT r5902-9c2ac19b03 / LuCI Master (git-18.021.64448-4dddecf), is there anything I can/should do to troubleshoot this, or should I just roll back to the stock firmware?

Aaron Z

Daniel Wandrei commented on 24.01.2018 07:36

Same for me, feels like it got even worse the last 2 weeks. I already opened a Bug about these Kernel warnings without any success. Looks like WDS has to be considered "unstable" on ath9k with Lede installed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing