OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Utpal Sarkar - 18.12.2017
Last edited by Adrian Schmutzler - 19.06.2020

FS#1230 - ADSL connection can't be established on Arcadyan ARV7518PW in LEDE 17.01

I have an Arcadyan ARV7518PW ADSL router on which I flashed U-Boot, and installed different versions of OpenWrt and LEDE. I only manage to get an ADSL connection with OpenWrt 14.07, and not on OpenWrt 15.05.1, LEDE 17.01.3 and LEDE 17.01.4.

I checked that the DSL firmware in /lib/firmware is identical in all these versions. I installed the packages in different ways (direct upload using httpd from U-Boot, upgrade from other version), even on different routers (I have 3 of these), with consistent results.

Please let me know whatever information you’d like me to add.


Closed by  Adrian Schmutzler
19.06.2020 11:23
Reason for closing:  Won't fix
Additional comments about closing:  

LEDE-17.01 has reached EOL (end of life). This bug has been closed automatically. If the problem persists with a newer version, please file an appropriate new bug report for that version.

Project Manager
Mathias Kresin commented on 10.01.2018 07:30

Please attach your /etc/config/network, the output of 'dmesg', the output of 'logread' and the output of '/etc/init.d/dsl_control status'.

Please provide some details about your provider.

Utpal Sarkar commented on 15.01.2018 18:39

Hi Mathias,

Part of what you are asking for can be found in my question https://forum.lede-project.org/t/problems-setting-up-arcadyan-arv7518pw-as-an-adsl-gateway/9517 (when I thought it would probably just be a misconfiguration). I'll copy the relevant parts here. I will add the remaining items you asked for later (when I install that version again).

My ISP provided me with the following (in Spanish, but should be easy to understand):

ATM PVC VPI/VCI : 8/32
Categoría de servicio : UBR
Multiplexación : PPPoE
Username PPP : adsl@masmovil
Password PPP : masmovil
Modo de encapsulación : LLC
DSL Type : ADSL2+
Versión de dirección IP: IPv4
802.1Q - VLAN : 20
MTU : 1488

This is what my /etc/config/network configuration file looks (I tried many different settings, but none of it worked):

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd59:32b9:4c4a::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	option ipaddr '192.168.2.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'

config atm-bridge 'atm'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option vpi '8'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '1'
	option username 'adsl@masmovil'
	option password 'masmovil'
	option metric '1488'
	option mtu '1488'
	option _orig_ifname 'nas0'
	option _orig_bridge 'false'
	option ifname 'nas0.20'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config adsl 'dsl'
	option annex 'a'
	option firmware '/lib/firmware/adsl.bin'

Output from ifconfig:

br-lan    Link encap:Ethernet  HWaddr 7C:4F:B5:18:A5:A4  
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::7e4f:b5ff:fe18:a5a4/64 Scope:Link
          inet6 addr: fd59:32b9:4c4a::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55741 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48626 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5000135 (4.7 MiB)  TX bytes:6057077 (5.7 MiB)

eth0      Link encap:Ethernet  HWaddr 7C:4F:B5:18:A5:A4  
          inet6 addr: fe80::7e4f:b5ff:fe18:a5a4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:29633 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23009 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3366385 (3.2 MiB)  TX bytes:3609745 (3.4 MiB)

eth0.1    Link encap:Ethernet  HWaddr 7C:4F:B5:18:A5:A4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:29631 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22995 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2773220 (2.6 MiB)  TX bytes:3469400 (3.3 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3284 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3284 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:233881 (228.3 KiB)  TX bytes:233881 (228.3 KiB)

nas0      Link encap:Ethernet  HWaddr 00:00:01:00:00:00  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

nas0.20   Link encap:Ethernet  HWaddr 00:00:01:00:00:00  
          UP BROADCAST MULTICAST  MTU:1488  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 7C:4F:B5:18:A5:A5  
          inet6 addr: fe80::7e4f:b5ff:fe18:a5a5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:26109 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2592435 (2.4 MiB)  TX bytes:3444530 (3.2 MiB)

dmesg output ends with

[   32.892848] device eth0.1 entered promiscuous mode
[   32.896227] device eth0 entered promiscuous mode
[   32.919960] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   34.006560] IPv6: ADDRCONF(NETDEV_UP): nas0: link is not ready
[   34.048332] IPv6: ADDRCONF(NETDEV_UP): nas0.20: link is not ready
[   34.584771] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   34.604352] br-lan: port 1(eth0.1) entered forwarding state
[   34.608567] br-lan: port 1(eth0.1) entered forwarding state
[   34.684292] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   35.557174] ath: EEPROM regdomain: 0x82d4
[   35.559690] ath: EEPROM indicates we should expect a country code
[   35.565688] ath: doing EEPROM country->regdmn map search
[   35.570821] ath: country maps to regdmn code: 0x37
[   35.575459] ath: Country alpha2 being used: ES
[   35.579769] ath: Regpair used: 0x37
[   35.583153] ath: regdomain 0x82d4 dynamically updated by user
[   36.612183] br-lan: port 1(eth0.1) entered forwarding state
[   38.995110] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   39.101758] device wlan0 entered promiscuous mode
[   40.078010] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   40.083226] br-lan: port 2(wlan0) entered forwarding state
[   40.088327] br-lan: port 2(wlan0) entered forwarding state
[   42.092183] br-lan: port 2(wlan0) entered forwarding state
[  139.341067] IPv6: ADDRCONF(NETDEV_UP): nas0: link is not ready
[  139.376758] IPv6: ADDRCONF(NETDEV_UP): nas0.20: link is not ready

where the last two appear after connecting the ADSL and pressing connect in LuCI.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing