OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category Kernel
  • Assigned To
    Yousong Zhou
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by djm300 - 11.12.2017
Last edited by Yousong Zhou - 26.01.2018

FS#1219 - ipt-debug module not compiling

Hello,

While I can compile the ipt-debug module (which provides the iptables TRACE target), it is not available for download in the LEDE packages repository. Compiling it myself works well (but then requires me to compile ALL kernel modules).

Since the kernel package KernelPackage/ipt-debug already exists but is not enabled by default, here’s my kind request to at least provide it as a package to default LEDE users should they want to use it.

Package info: cat package/linux/modules/netfilter.mk | grep -b5 -B5 -n debug

Supply the following if possible:
- Device problem occurs on
- Software versions of LEDE release, packages, etc.
- Steps to reproduce

  1. > With default feeds, opkg install kmod-ipt-debug does not work.
  2. > in a build environment, kmod-ipt-debug can be compiled via CONFIG_PACKAGE_kmod-ipt-debug=m and the package is then available in the bin/targets/ar71xx/generic/packages folder

Best regards
Joris


Closed by  Yousong Zhou
26.01.2018 07:30
Reason for closing:  Fixed
Additional comments about closing:  

Fixed by e6de92cdcc31c68c56fa0c5b0c82ee4c56a95218

Project Manager
Yousong Zhou commented on 26.01.2018 07:40

The fix was also backported to lede-17.01 branch:

fbeae9d iptables: make kmod-ipt-debug part of default ALL build
6ea9a70 iptables: Fix target TRACE issue

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing