OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Connor - 12.11.2017
Last edited by Mathias Kresin - 13.11.2017

FS#1166 - kmod-usb-net and kmod-lib-lzo incomplete on target bcm2710/Raspberry Pi 3B

Installed a fresh version of LEDE 17.01.4 on Raspberry Pi 3B:

https://downloads.lede-project.org/releases/17.01.4/targets/brcm2708/bcm2710/lede-17.01.4-brcm2708-bcm2710-rpi-3-ext4-sdcard.img.gz

When installing (opkg install) kmod-usb-net and kmod-lib-lzo the following errors appear:

Configuring kmod-usb-net.
failed to find a module named usbnet

Configuring kmod-lib-lzo.
failed to find a module named lzo_compress
failed to find a module named lzo_decompress

Afair, both worked last with LEDE 17.01.1 and are broken since LEDE 17.01.2.

Closed by  Mathias Kresin
13.11.2017 10:44
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#893 

Connor commented on 12.11.2017 16:47

Apparently when you collect information from similar bug reports, those two packages are stubs now when used with Raspberry Pi 3B as the contained functionality has moved from modules into the kernel.

So the problem seems to be packaging rather than functionality.

Derived from contents of those two bug reports:

https://bugs.lede-project.org/index.php?do=details&task_id=893

https://bugs.lede-project.org/index.php?do=details&task_id=1092

Project Manager
Mathias Kresin commented on 13.11.2017 10:44

Please don't create duplicate bugreports. The issue is already tracked in  FS#893  as you noticed by your self.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing