OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version lede-17.01
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Benjamin Henrion - 30.10.2017
Last edited by Yousong Zhou - 27.02.2018

FS#1128 - Make is segfaulting with SDK lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64

On an ubuntu 16.04 docker container with all the host tools installed via “apt-get install build-essential subversion libncurses5-dev zlib1g-dev gawk gcc-multilib flex git-core gettext libssl-dev unzip”, I installed this SDK:

lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64.tar.xz

When I untar it and go into:

$ cd lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64
$ make
Segmentation fault (core dumped)
                                /mnt/ar71xx/lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64/include/toplevel.mk:127: recipe for target 'menuconfig' failed
                                                    make[2]: *** [menuconfig] Error 139
                                                                                       make[2]: Leaving directory '/mnt/ar71xx/lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64'
                                                                         /mnt/ar71xx/lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64/include/toplevel.mk:94: recipe for target '.config' failed
                                                                                         make[1]: *** [.config] Error 2
                                                                                                                       /mnt/ar71xx/lede-sdk-17.01.4-ar71xx-generic_gcc-5.4.0_musl-1.1.16.Linux-x86_64/include/toplevel.mk:191: recipe for target 'world' failed
             make: *** [world] Error 2

Can you reproduce it?

Closed by  Yousong Zhou
27.02.2018 07:44
Reason for closing:  Works for me
Admin
Jo-Philipp Wich commented on 01.11.2017 13:41

I am unable to reproduce it on an Ubuntu 16.04.1 or a Debian 10 host.

Project Manager
Yousong Zhou commented on 30.01.2018 06:32

Cannot reproduce it with ubuntu:16.04 container on centos7. It works fine there.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing