OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Christian Schoenebeck - 28.10.2017
Last edited by Yousong Zhou - 01.02.2018

FS#1123 - base-files: os-release: HOME_URL not settable / set to LEDE_DEVICE_MANUFACTURER_URL

Device independent
LEDE 17.01.4 and LEDE r5201-8b9cdebc9c

Set
→ Image configuration
→ Version configuration options
→ Manufacturer URL to a non-empty value and build

Problem:

  1. HOME_URL set to LEDE_DEVICE_MANUFACTURER_URL
  2. HOME_URL is nowhere settable inside “make menuconfig”
  3. If Manufacturer URL is cleared, HOME_URL still set after rebuild
Closed by  Yousong Zhou
01.02.2018 05:11
Reason for closing:  Not a bug
Project Manager
Yousong Zhou commented on 01.02.2018 05:25

LEDE_DEVICE_xxx vars should be device-specific instead of being a global option. I guess the option was previously introduced for oem users. As such setting HOME_URL also to LEDE_DEVICE_MANUFACTURER_URL with a default value of upstream homepage makes sense.

I cannot reproduce the 3rd issue about LEDE_DEVICE_MANUFACTURER_URL and HOME_URL not being in sync. It works as expected here.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing