OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Piotr Dymacz
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by nektarin - 19.10.2017
Last edited by Piotr Dymacz - 19.10.2017

FS#1082 - TP-link 1043 nd comes into boot loop in 17.01.4

After flashing 17.01.4 to tl1043nd version 1.8 the device became in boot loop without even coming to SYS led blinking. Trying to get it into recovery mode did not work, I assume it does not start up to that point.

Closed by  Piotr Dymacz
19.10.2017 18:07
Reason for closing:  Works for me
Additional comments about closing:  

17.01.4 sysupgrade and factory images were tested on real hardware, no issues were found.

Project Manager
Piotr Dymacz commented on 19.10.2017 13:15

Hi @nektarin,

Could you check if your device contains tftp recovery mode in U-Boot [1]?
If it does, could please upload again 17.01.4 factory image and see if it works?

Do you maybe have (or can make) serial access to your device?

[1] https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd#flashingrecovery_using_tftp_only_without_serial_console

Cheers,
Piotr

nektarin commented on 19.10.2017 14:24

I tried the tftp recovery, as I said the router did not react to pressing the reset button at all. I am going to try the serial access when I get the ttl adapter.

Project Manager
Piotr Dymacz commented on 19.10.2017 18:05

Hi @nektarin,

People sometimes call "failsafe" a "recovery" mode, that's why I got confused and asked about "tftp recovery".

I have just tried 17.01.4 (factory and sysupgrade from 17.01.3) on a v1.8 of this model (with last available vendor firmware: 140319), without any issues.

BusyBox v1.25.1 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (17.01.4, r3560-79f57e422d)
    \________\/    -----------------------------------------------------------

=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@LEDE:/# cat /tmp/sysinfo/board_name
tl-wr1043nd
root@LEDE:/# cat /tmp/sysinfo/model
TP-Link TL-WR1043N/ND v1

Maybe something went wrong during the upgrade. Full bootlog from the serial console should tell you more - please reopen this ticket or issue another one when you get more details.

Cheers,
Piotr

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing