OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Ivan Grinko - 16.10.2017
Last edited by Mathias Kresin - 25.10.2017

FS#1061 - Build failure at current trunk

Trunk is at 0d5c1d7f238cd5aca207268950edc70ed6cf0a05
Most likely this happens because of toolchain/glibc upgrade

lib/libmtd_legacy.c:255:15: warning: implicit declaration of function ‘minor’ [-Wimplicit-function-declaration]

mtd->minor = minor(st.st_rdev);
             ^~~~~
CC      lib/libcrc32.o
CC      lib/libfec.o
AR      lib/libmtd.a
LD      mkfs.jffs2

/mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.o: In function `write_special_file’:
/mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:944: undefined reference to `major’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:944: undefined reference to `minor’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.o: In function `recursive_populate_directory’:
/mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:1263: undefined reference to `minor’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:1263: undefined reference to `major’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:1273: undefined reference to `minor’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:1273: undefined reference to `major’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.o: In function `interpret_table_entry’:
/mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:503: undefined reference to `makedev’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:467: undefined reference to `makedev’ /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2.c:510: undefined reference to `makedev’ collect2: error: ld returned 1 exit status
make[4]: * [common.mk:81: /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/mkfs.jffs2] Error 1
make[4]: Leaving directory ‘/mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2’ make[3]:
* [Makefile:56: /mnt/sdb2/lede/lede/build_dir/host/mtd-utils-1.5.2/.built] Error 2
make[3]: Leaving directory ‘/mnt/sdb2/lede/lede/tools/mtd-utils’ make[2]: *** [tools/Makefile:150: tools/mtd-utils/compile] Error 2
make[2]: Leaving directory ‘/mnt/sdb2/lede/lede’


Closed by  Mathias Kresin
25.10.2017 10:18
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#1015 

bugmenot commented on 21.10.2017 19:19

Duplicate of bug #1015. You can apply patch, but there are tons of other bugs along the way.

https://bugs.lede-project.org/index.php?do=details&task_id=1015&status%5B0%5D=&order=status&sort=asc&order2=id&sort2=desc

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing