OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Bluse-Blue - 21.08.2016
Last edited by Ted Hess - 27.08.2016

FS#106 - TPLink CPE510 - eth0 (ag71xx): transmit queue 0 timed out & eth0: tx timeout

Hi all,

problem description

Ethernet is not working on TPLink CPE510 whith current LEDE after booting with an Ethernet cable pluged in and ipip package installed.
With the default image installed, Ethernet is working. After

opkg install ipip

the ethernet problem appears on each reboot.

Error messafe via dmesg output

[    8.530755] procd: - ubus -
[    8.588985] procd: - init -
Please press Enter to activate this console.
[    9.036308] ipip: IPv4 over IPv4 tunneling driver
[    9.059347] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    9.090320] Loading modules backported from Linux version wt-2016-06-20-0-gbc17424
[    9.098073] Backport generated by backports.git backports-20160216-7-g5735958
[    9.146639] ip_tables: (C) 2000-2006 Netfilter Core Team
[    9.173610] nf_conntrack version 0.5.0 (942 buckets, 3768 max)
[    9.229091] xt_time: kernel timezone is -0000
[    9.308395] PPP generic driver version 2.4.2
[    9.316698] NET: Registered protocol family 24
[    9.393923] ieee80211 phy0: Atheros AR9340 Rev:2 mem=0xb8100000, irq=47
[   17.462583] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   17.472412] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[   17.511841] IPv6: ADDRCONF(NETDEV_UP): eth0.7: link is not ready
[   19.056923] eth0: link up (1000Mbps/Full duplex)
[   19.061648] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   19.069793] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   19.076618] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.7: link becomes ready
[   29.065183] ------------[ cut here ]------------
[   29.069936] WARNING: CPU: 0 PID: 0 at net/sched/sch_generic.c:306 dev_watchdog+0x1dc/0x260()
[   29.078518] NETDEV WATCHDOG: eth0 (ag71xx): transmit queue 0 timed out
[   29.085137] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables ipip tunnel4 ip_tunnel gpio_button_hotplug
[   29.148515] CPU: 0 PID: 0 Comm: swapper Not tainted 4.4.15 #0
[   29.154341] Stack : 803de5a4 00000000 00000001 80430000 804291b8 80428e43 803bfc44 00000000
          80493798 804274dc 00000200 00100000 0000000a 800a6fbc 803c52a8 80420000
          00000003 804274dc 803c36b4 80423c2c 0000000a 800a4f38 00000006 00000000
          00000000 801f3a00 00000000 00000000 00000000 00000000 00000000 00000000
          00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
          ...
[   29.190720] Call Trace:
[   29.193217] [<80071b48>] show_stack+0x50/0x84
[   29.197665] [<80081884>] warn_slowpath_common+0xa0/0xd0
[   29.202970] [<800818e0>] warn_slowpath_fmt+0x2c/0x38
[   29.208028] [<8028afac>] dev_watchdog+0x1dc/0x260
[   29.212821] [<800b01a8>] call_timer_fn.isra.5+0x24/0x80
[   29.218136] [<800b042c>] run_timer_softirq+0x1b4/0x1fc
[   29.223353] [<80083e00>] __do_softirq+0x250/0x298
[   29.228158] [<8006a6f0>] plat_irq_dispatch+0xd4/0x10c
[   29.233284] [<80060830>] ret_from_irq+0x0/0x4
[   29.237734] [<8006e9e8>] r4k_wait_irqoff+0x18/0x20
[   29.242597] [<800a2118>] cpu_startup_entry+0x9c/0xe8
[   29.247653] [<80449bd4>] start_kernel+0x470/0x490
[   29.252426]
[   29.253941] ---[ end trace ccce8c99862bd079 ]---
[   29.258634] eth0: tx timeout
[   39.065184] eth0: tx timeout
[   49.065185] eth0: tx timeout
[   69.065184] eth0: tx timeout
[   76.585216] random: nonblocking pool is initialized
[   79.065183] eth0: tx timeout
[   94.065185] eth0: tx timeout
[  104.065185] eth0: tx timeout
[  134.065183] eth0: tx timeout
[  159.065184] eth0: tx timeout
[  169.065184] eth0: tx timeout
[  179.065183] eth0: tx timeout
[  199.065181] eth0: tx timeout
[  209.065182] eth0: tx timeout

hardware TPLink CPE510

software default LEDE (HEAD, r1396) from lede download & package ipip (inkludes kmod-ipip)

workaround

  • do not use ipip
  • plug Ethernet cable after reboot is finished

steps to reproduce

  1. install default CPE510 image from lede-project download folder to CPE510
  1. install ipip package
    opkg install ipip
  1. reboot & watch dmesg via serial console

troubleshoting steps so far

  • switch from custom build to default image from lede-project (same issue after installing ipip)

As I am not familiar with the ar71xx Eternet driver I would ask for further troubleshooting hints.

Greetings from Berlin
Thomas

Closed by  Ted Hess
27.08.2016 13:38
Reason for closing:  Not a bug
Project Manager
Piotr Dymacz commented on 21.08.2016 15:17
Bluse-Blue commented on 21.08.2016 21:03

Hi all,

Some more troubleshooting infos I just gathers from observing the issue:

  1. when connecting the Ethernet cable after the reboot process has finished, dmesg on the CPE510 shows
    eth0: link up (1000Mbps/Full duplex)

    , but the NIC is 100MBit and not 1000MBit. My Laptop show 100MBit when Ethernet connection is establied

  2. when connecting the Ethernet cable after the reboot process has finished, ethool seem to have problem to get the Ethnernet device settings:
root@new-evernetlter / # ifconfig
eth0      Link encap:Ethernet  HWaddr F4:F2:6D:FF:E6:C2
          inet6 addr: fe80::f6f2:6dff:feff:e6c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24482 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44657 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1967103 (1.8 MiB)  TX bytes:63737318 (60.7 MiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr F4:F2:6D:FF:E6:C2
          inet addr:10.10.200.1  Bcast:10.10.200.255  Mask:255.255.255.0
          inet6 addr: fe80::f6f2:6dff:feff:e6c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24482 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44285 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1526427 (1.4 MiB)  TX bytes:63434726 (60.4 MiB)

eth0.7    Link encap:Ethernet  HWaddr F4:F2:6D:FF:E6:C2
          inet6 addr: fe80::f6f2:6dff:feff:e6c2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:365 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:123174 (120.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:160 errors:0 dropped:0 overruns:0 frame:0
          TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:9120 (8.9 KiB)  TX bytes:9120 (8.9 KiB)

root@new-evernetlter / # ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes
root@new-evernetlter / # ethtool eth0.1
Settings for eth0.1:
Cannot get device settings: No such device
        Link detected: yes
root@new-evernetlter / # ethtool eth0.7
Settings for eth0.7:
Cannot get device settings: No such device
        Link detected: yes

Greetings Thomas

Bluse-Blue commented on 25.08.2016 22:04

Hi all,

A nice troubleshooting at Cbase with the help of nbd revealed the ethernet driver problem was caused by the flow control feature. As soon as it is disabled, booting with Ethernet cable connected works again. This https://github.com/lede-project/source/commit/83997146e76d4097e30facf6ad89e5fa3bd7c65b fixes the issue.

Greetings from Berlin
Bluse

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing