Flyspray:: https://bugs.openwrt.org/ Flyspray::OpenWrt/LEDE Project: Recently opened tasks 2019-06-19T18:23:43Z FS#2331: Package request: libbpf package https://bugs.openwrt.org/index.php?do=details&task_id=2331 2019-06-19T18:23:43Z Michael Jones Needed for many types of eBPF usage: https://github.com/libbpf/libbpf Needed for many types of eBPF usage: https://github.com/libbpf/libbpf

]]>
FS#2330: Samba - smb.conf templating allows arbitrary injections of samba configurations https://bugs.openwrt.org/index.php?do=details&task_id=2330 2019-06-19T15:45:07Z Luca Piccirillo First, I have to say I’m not 100% sure it is something to be addressed within samba package itself, so forgive me if this is something you have already evaluated as not being an issue. In short, something like that works: […] option workgroup 'WORKGROUP\ security = share\ guest account = root\ interfaces = lo br-lan\ \ [ohnonotagain]' I’m not sure this works in plain openwrt images, but there exists a widely deployed commercial fork of openwrt which is definitely vulnerable to some exploit chain involving this one in the middle.You could argue that the right of modifying uci config already gives an equivalent authorization level, or this should have been sanitized at user interface. So, is this something you consider safe? First, I have to say I’m not 100% sure it is something to be addressed within samba package itself, so forgive me if this is something you have already evaluated as not being an issue.

In short, something like that works:

 […]
    option workgroup 'WORKGROUP\
    security = share\
    guest account = root\
    interfaces = lo br-lan\
\
[ohnonotagain]'

I’m not sure this works in plain openwrt images, but there exists a widely deployed commercial fork of openwrt which is definitely vulnerable to some exploit chain involving this one in the middle.
You could argue that the right of modifying uci config already gives an equivalent authorization level, or this should have been sanitized at user interface. So, is this something you consider safe?

]]>
FS#2329: openvpn: Options error: You must define TUN/TAP device (--dev) https://bugs.openwrt.org/index.php?do=details&task_id=2329 2019-06-19T14:07:45Z AbraxasDMG Hi! Installation of OpenWrt 18.06.2 On Linksys E900 router.Nothing extraordinary in relation to flashing and initial configuration. Configure first lan port as a connection towards the internal network. Everything working as expected.Installed openvpn-openssl. Tried to configure it and ran into the error “Options error: You must define TUN/TAP device (–dev)”. Nothing I tried resulted in disappearance of that error message. Below are relevant configuration snippets. /etc/config/networkconfig interface ‘loopback’ option ifname ‘lo’ option proto ‘static’ option ipaddr ‘127.0.0.1’ option netmask ‘255.0.0.0’ config globals ‘globals’ option ula_prefix ‘fdd3:5676:7153::/48’ config interface ‘lan’ option type ‘bridge’ option ifname ‘eth0.1’ option proto ‘static’ option netmask ‘255.255.255.0’ option ipaddr ‘192.168.100.2’ option dns ‘192.168.100.1’ option gateway ‘192.168.100.1’ option delegate ‘0’ config interface ‘wan’ option ifname ‘eth0.2’ option proto ‘dhcp’ option auto ‘0’ config interface ‘wan6’ option ifname ‘eth0.2’ option proto ‘dhcpv6’ option auto ‘0’ config switchoption name ‘switch0’ option reset ‘1’ option enable_vlan ‘1’ config switch_vlanoption device ‘switch0’ option vlan ‘1’ option ports ‘0 1 2 3 5t’ config switch_vlanoption device ‘switch0’ option vlan ‘2’ option ports ‘4 5t’ config interface ‘vpn’ option proto ‘none’ option ifname ‘tun0’ option auto ‘1’ /etc/config/openvpnconfig openvpn ‘udp1194’ option keepalive ‘10 60’ option server ‘192.168.168.0 255.255.255.0’ option persist_tun ‘1’ option persist_key ‘1’ option tls_auth ‘/etc/openvpn/ta.key’ option ca ‘/etc/openvpn/ca.crt’ option cert ‘/etc/openvpn/server.crt’ option key ‘/etc/openvpn/server.key’ option dh ‘/etc/openvpn/dh.pem’ option key_direction ‘0’ list push ‘redirect-gateway def1’ list push ‘dhcp-option DNS 8.8.4.4’ list push ‘dhcp-option DNS 8.8.8.8’ list push ‘block-outside-dns’ option cipher ‘AES-256-CBC’ option auth ‘SHA256’ option proto ‘udp’ option port ‘1194’ option enabled ‘1’ option verb ‘9’ option log_append ‘/tmp/openvpn-udp1194.log’ option dev ‘tun’ Thank you very much in advance. Hi!

Installation of OpenWrt 18.06.2 On Linksys E900 router.
Nothing extraordinary in relation to flashing and initial configuration.

Configure first lan port as a connection towards the internal network. Everything working as expected.
Installed openvpn-openssl. Tried to configure it and ran into the error “Options error: You must define TUN/TAP device (–dev)”.

Nothing I tried resulted in disappearance of that error message.

Below are relevant configuration snippets.

/etc/config/network
config interface ‘loopback’ option ifname ‘lo’ option proto ‘static’ option ipaddr ‘127.0.0.1’ option netmask ‘255.0.0.0’

config globals ‘globals’ option ula_prefix ‘fdd3:5676:7153::/48’

config interface ‘lan’ option type ‘bridge’ option ifname ‘eth0.1’ option proto ‘static’ option netmask ‘255.255.255.0’ option ipaddr ‘192.168.100.2’ option dns ‘192.168.100.1’ option gateway ‘192.168.100.1’ option delegate ‘0’

config interface ‘wan’ option ifname ‘eth0.2’ option proto ‘dhcp’ option auto ‘0’

config interface ‘wan6’ option ifname ‘eth0.2’ option proto ‘dhcpv6’ option auto ‘0’

config switch
option name ‘switch0’ option reset ‘1’ option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’ option vlan ‘1’ option ports ‘0 1 2 3 5t’

config switch_vlan
option device ‘switch0’ option vlan ‘2’ option ports ‘4 5t’

config interface ‘vpn’ option proto ‘none’ option ifname ‘tun0’ option auto ‘1’

/etc/config/openvpn
config openvpn ‘udp1194’ option keepalive ‘10 60’ option server ‘192.168.168.0 255.255.255.0’ option persist_tun ‘1’ option persist_key ‘1’ option tls_auth ‘/etc/openvpn/ta.key’ option ca ‘/etc/openvpn/ca.crt’ option cert ‘/etc/openvpn/server.crt’ option key ‘/etc/openvpn/server.key’ option dh ‘/etc/openvpn/dh.pem’ option key_direction ‘0’ list push ‘redirect-gateway def1’ list push ‘dhcp-option DNS 8.8.4.4’ list push ‘dhcp-option DNS 8.8.8.8’ list push ‘block-outside-dns’ option cipher ‘AES-256-CBC’ option auth ‘SHA256’ option proto ‘udp’ option port ‘1194’ option enabled ‘1’ option verb ‘9’ option log_append ‘/tmp/openvpn-udp1194.log’ option dev ‘tun’

Thank you very much in advance.

 


]]>
FS#2328: Allocate resources to sort out odhcpd/dnsmasq interaction once and for all. https://bugs.openwrt.org/index.php?do=details&task_id=2328 2019-06-18T11:31:40Z Kevin 'ldir' Darbyshire-Bryant As IPv6 is being adopted, increasingly people are seeing dnsmasq log ‘spam’. See https://bugs.openwrt.org/index.php?do=details&task_id=1492&string=1492&search_name=&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto= By default under openwrt, dhcpv4 leases are handled by dnsmasq whilst dhcpv6/RA is handled by openwrt’s odhcpd. odhcpd could handle both v4 & v6 but does not yet have the same configuration flexibility for dhcp options as dnsmasq. I guess this is why no one has been brave enough to switch to odhcpd for ipv4 operations as well as ipv6. dnsmasq can also handle dhcpv6/RA but not quite as flexibly as odhcpd. dnsmasq will automatically find IP6 prefixes on interfaces and start handling them, whilst openwrt’s strategy with odhcpd is to only handle stuff we tell you to handle, don’t do it automagically. As dnsmasq is the default resolver for openwrt and the wider LAN, it needs to know about DHCP/hostname allocations. For DHCPv4 this is easy, dnsmasq is controlling them. For DHCPv6 a hosts file (called a statefile in the odhcpd code) is handed to dnsmasq. By default this host file is not read dynamically, so odhcpd has to signal dnsmasq to re-read the host file (and clear caches etc etc) upon every ipv6 lease change. This generates a lot of log spam and process startup overhead. There are also questions about service operability during this time. Effort needs to be put into sorting this out. Temporary workarounds: Use ‘hostsdir’ dnsmasq option instead of ‘addn-hosts’ - dnsmasq will dynamically scan changes/additions to hosts in hostsdir whereas addn-hosts needs a SIGHUP. Host deletions cannot be handled by this method, so odhcpd would still need to SIGHUP on lease expiry. It might reduce some of the spam. Longer term: Teach dnsmasq to accept hostname updates over an IPC mechanism. ubus? and carry on using odhcpd for ipv6. Teach dnsmasq to handle ipv6 prefix additions/deletions/handling via an IPC mechanism in the same way as odhcpd. Drop odhcpd and use dnsmasq for everything. Use odhcpd for everything and use another dns resolver that interfaces nicely with odhcpd. Why don’t I see this problem: I use dnsmasq to handle ipv6 but I’m lucky enough that this works for me. This needs fixing/funding to sort it out though. As IPv6 is being adopted, increasingly people are seeing dnsmasq log ‘spam’. See https://bugs.openwrt.org/index.php?do=details&task_id=1492&string=1492&search_name=&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

By default under openwrt, dhcpv4 leases are handled by dnsmasq whilst dhcpv6/RA is handled by openwrt’s odhcpd.

odhcpd could handle both v4 & v6 but does not yet have the same configuration flexibility for dhcp options as dnsmasq. I guess this is why no one has been brave enough to switch to odhcpd for ipv4 operations as well as ipv6.

dnsmasq can also handle dhcpv6/RA but not quite as flexibly as odhcpd. dnsmasq will automatically find IP6 prefixes on interfaces and start handling them, whilst openwrt’s strategy with odhcpd is to only handle stuff we tell you to handle, don’t do it automagically.

As dnsmasq is the default resolver for openwrt and the wider LAN, it needs to know about DHCP/hostname allocations. For DHCPv4 this is easy, dnsmasq is controlling them. For DHCPv6 a hosts file (called a statefile in the odhcpd code) is handed to dnsmasq.

By default this host file is not read dynamically, so odhcpd has to signal dnsmasq to re-read the host file (and clear caches etc etc) upon every ipv6 lease change.

This generates a lot of log spam and process startup overhead. There are also questions about service operability during this time.

Effort needs to be put into sorting this out.

Temporary workarounds:

Use ‘hostsdir’ dnsmasq option instead of ‘addn-hosts’ - dnsmasq will dynamically scan changes/additions to hosts in hostsdir whereas addn-hosts needs a SIGHUP. Host deletions cannot be handled by this method, so odhcpd would still need to SIGHUP on lease expiry. It might reduce some of the spam.

Longer term:

Teach dnsmasq to accept hostname updates over an IPC mechanism. ubus? and carry on using odhcpd for ipv6.

Teach dnsmasq to handle ipv6 prefix additions/deletions/handling via an IPC mechanism in the same way as odhcpd. Drop odhcpd and use dnsmasq for everything.

Use odhcpd for everything and use another dns resolver that interfaces nicely with odhcpd.

Why don’t I see this problem: I use dnsmasq to handle ipv6 but I’m lucky enough that this works for me.

This needs fixing/funding to sort it out though.

]]>
FS#2327: /boot mounted multiple times https://bugs.openwrt.org/index.php?do=details&task_id=2327 2019-06-18T10:50:02Z Kevin 'ldir' Darbyshire-Bryant Supply the following if possible: - Device problem occurs on- seen on x86 APU2 - may be others. - Software versions of OpenWrt master - Steps to reproduce - boot system root@Router:~# dfFilesystem 1K-blocks Used Available Use% Mounted on/dev/root 14080 14080 0 100% /romtmpfs 2011892 156 2011736 0% /tmp/dev/loop0 246016 15140 161244 9% /overlayoverlayfs:/overlay 246016 15140 161244 9% //dev/sda1 16112 4172 11616 26% /boot/dev/sda1 16112 4172 11616 26% /boottmpfs 512 0 512 0% /devroot@Router:/etc/config# block info/dev/loop0: UUID=”cbbd153a-60b0-40e0-800e-b79833957b9f” VERSION=”1.12” MOUNT=”/overlay” TYPE=”f2fs” /dev/sda1: UUID=”57f8f4bc-abf4-655f-bf67-946fc0f9f25b” VERSION=”1.0” MOUNT=”/boot” TYPE=”ext4” /dev/sda2: UUID=”b9caa0dd-b7eb255f-2c2775da-3aa40e49” VERSION=”4.0” MOUNT=”/rom” TYPE=”squashfs” /dev/sda3: UUID=”e92b8416-fe49-409b-a4cf-c71476027159” VERSION=”1.12” MOUNT=”/mnt/sda3” TYPE=”f2fs” root@Router:/etc/config# cat /etc/config/fstab config global option anon_swap '0' option anon_mount '0' option auto_swap '1' option auto_mount '1' option delay_root '5' option check_fs '1' config mount option target '/mnt/loop0' option uuid 'dd87006a-ba8e-44f4-a40b-f2cb6181dc4e' option enabled '0' config mount option target '/mnt/sda1' option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b' option enabled '0' config mount option target '/mnt/sda2' option uuid '8a1c0748-3d6b7bd1-0192e5c4-7fe0165c' option enabled '0' config mount option target '/mnt/sda3' option uuid 'e92b8416-fe49-409b-a4cf-c71476027159' option enabled '1' root@Router:/etc/config# uname -aLinux Router 4.14.126 #0 SMP Tue Jun 18 09:45:23 2019 x86_64 GNU/Linux Supply the following if possible:
- Device problem occurs on- seen on x86 APU2 - may be others.
- Software versions of OpenWrt master
- Steps to reproduce - boot system

root@Router:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 14080 14080 0 100% /rom
tmpfs 2011892 156 2011736 0% /tmp
/dev/loop0 246016 15140 161244 9% /overlay
overlayfs:/overlay 246016 15140 161244 9% /
/dev/sda1 16112 4172 11616 26% /boot
/dev/sda1 16112 4172 11616 26% /boot
tmpfs 512 0 512 0% /dev
root@Router:/etc/config# block info
/dev/loop0: UUID=”cbbd153a-60b0-40e0-800e-b79833957b9f” VERSION=”1.12” MOUNT=”/overlay” TYPE=”f2fs” /dev/sda1: UUID=”57f8f4bc-abf4-655f-bf67-946fc0f9f25b” VERSION=”1.0” MOUNT=”/boot” TYPE=”ext4” /dev/sda2: UUID=”b9caa0dd-b7eb255f-2c2775da-3aa40e49” VERSION=”4.0” MOUNT=”/rom” TYPE=”squashfs” /dev/sda3: UUID=”e92b8416-fe49-409b-a4cf-c71476027159” VERSION=”1.12” MOUNT=”/mnt/sda3” TYPE=”f2fs” root@Router:/etc/config# cat /etc/config/fstab

config global

option anon_swap '0'
option anon_mount '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '5'
option check_fs '1'

config mount

option target '/mnt/loop0'
option uuid 'dd87006a-ba8e-44f4-a40b-f2cb6181dc4e'
option enabled '0'

config mount

option target '/mnt/sda1'
option uuid '57f8f4bc-abf4-655f-bf67-946fc0f9f25b'
option enabled '0'

config mount

option target '/mnt/sda2'
option uuid '8a1c0748-3d6b7bd1-0192e5c4-7fe0165c'
option enabled '0'

config mount

option target '/mnt/sda3'
option uuid 'e92b8416-fe49-409b-a4cf-c71476027159'
option enabled '1'

root@Router:/etc/config# uname -a
Linux Router 4.14.126 #0 SMP Tue Jun 18 09:45:23 2019 x86_64 GNU/Linux


]]>
FS#2326: page_owner=on doesn't work on Firefly FireWRT https://bugs.openwrt.org/index.php?do=details&task_id=2326 2019-06-18T02:25:28Z siweixiang use ‘make kernel_menuconfig’ to configure page_owner function and add page_owner=on to kernel boot cmdline compile, and update the Firefly FireWRT board login into the system, cat ‘/sys/kernel/debug/page_owner’, no output
  • use ‘make kernel_menuconfig’ to configure page_owner function and add page_owner=on to kernel boot cmdline
    1. compile, and update the Firefly FireWRT board
    1. login into the system, cat ‘/sys/kernel/debug/page_owner’, no output
    ]]>
    FS#2325: TPLink Archer C50 v4. opkg list update successful. 'Cannot install package' error for Luci https://bugs.openwrt.org/index.php?do=details&task_id=2325 2019-06-17T17:38:24Z Bill latest snapshot sysupgrade.bin image modified as per notes in this commit to enable initial install.https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=01dcd574a24864c10a9c4df4304a3ce0da5c11a9 See also my post on forum for more information.https://forum.openwrt.org/t/support-for-archer-c50-v4/20174/107 | |.-----.-----.-----.| | | |.----.| |_ | - || _ | -__| || | | || _|| _| |_______|| __|_____|__|__||________||__| |____| |__| W I R E L E S S F R E E D O M ----------------------------------------------------- OpenWrt SNAPSHOT, r10242-3c401f45c9 ----------------------------------------------------- === WARNING! ===================================== There is no root password defined on this device! Use the "passwd" command to set up a new password in order to prevent unauthorized SSH logins. -------------------------------------------------- root@OpenWrt:~# df Filesystem 1K-blocks Used Available Use% Mounted on /dev/root 2048 2048 0 100% /rom tmpfs 29636 60 29576 0% /tmp /dev/mtdblock5 3840 280 3560 7% /overlay overlayfs:/overlay 3840 280 3560 7% / tmpfs 512 0 512 0% /dev root@OpenWrt:~# opkg update Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_core Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4.14.125-1-e12d1ba9b9a71c449bb345046c7edbf7/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_kmods Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4.14.125-1-e12d1ba9b9a71c449bb345046c7edbf7/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_base Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_luci Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_packages Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_routing Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.sig Signature check passed. Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz Updated list of available packages in /var/opkg-lists/openwrt_telephony Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.sig Signature check passed. root@OpenWrt:~# root@OpenWrt:~# root@OpenWrt:~# opkg install luci Unknown package 'luci'. Collected errors: * opkg_install_cmd: Cannot install package luci. root@OpenWrt:~# Log is for attempting to install Luci. Same error for other known packages such as ‘openvpn-openssl’ and non-existent package names. I think this may be a bug, unless it is simply because the device does not have free space (8 MiB flash) to install luci etc? (I also installed latest snapshot to a spare HomeHub5A. No issues downloading/installing Luci or other packages but HH5A does have 128 MiB of flash) latest snapshot sysupgrade.bin image modified as per notes in this commit to enable initial install.
    https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=01dcd574a24864c10a9c4df4304a3ce0da5c11a9

    See also my post on forum for more information.
    https://forum.openwrt.org/t/support-for-archer-c50-v4/20174/107

     |       |.-----.-----.-----.|  |  |  |.----.|  |_
     |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
     |_______||   __|_____|__|__||________||__|  |____|
              |__| W I R E L E S S   F R E E D O M
     -----------------------------------------------------
     OpenWrt SNAPSHOT, r10242-3c401f45c9
     -----------------------------------------------------
    === WARNING! =====================================
    There is no root password defined on this device!
    Use the "passwd" command to set up a new password
    in order to prevent unauthorized SSH logins.
    --------------------------------------------------
    root@OpenWrt:~# df
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/root                 2048      2048         0 100% /rom
    tmpfs                    29636        60     29576   0% /tmp
    /dev/mtdblock5            3840       280      3560   7% /overlay
    overlayfs:/overlay        3840       280      3560   7% /
    tmpfs                      512         0       512   0% /dev
    
    root@OpenWrt:~# opkg update
    Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_core
    Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/packages/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4.14.125-1-e12d1ba9b9a71c449bb345046c7edbf7/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_kmods
    Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/kmods/4.14.125-1-e12d1ba9b9a71c449bb345046c7edbf7/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_base
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_luci
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_packages
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_routing
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.sig
    Signature check passed.
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz
    Updated list of available packages in /var/opkg-lists/openwrt_telephony
    Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.sig
    Signature check passed.
    root@OpenWrt:~#
    root@OpenWrt:~#
    root@OpenWrt:~# opkg install luci
    Unknown package 'luci'.
    Collected errors:
     * opkg_install_cmd: Cannot install package luci.
    root@OpenWrt:~#
    
    

    Log is for attempting to install Luci. Same error for other known packages such as ‘openvpn-openssl’ and non-existent package names.

    I think this may be a bug, unless it is simply because the device does not have free space (8 MiB flash) to install luci etc?

    (I also installed latest snapshot to a spare HomeHub5A. No issues downloading/installing Luci or other packages but HH5A does have 128 MiB of flash)

    ]]>
    FS#2324: Packages corrupt or empty https://bugs.openwrt.org/index.php?do=details&task_id=2324 2019-06-17T12:10:55Z ner0 Supply the following if possible: - TL-WR841N v13 - latest snapshot from ‘http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/’ - Trying to install ‘luci’ via opkg, getting: Unknown package ‘luci’.Collected errors: * opkg_install_cmd: Cannot install package luci. Checked the ‘mipsel_24kc’ folder and it has empty/corrupt files which would account for the issue: http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/ Supply the following if possible:
    - TL-WR841N v13
    - latest snapshot from ‘http://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/’ - Trying to install ‘luci’ via opkg, getting:

    Unknown package ‘luci’.
    Collected errors:
    * opkg_install_cmd: Cannot install package luci.

    Checked the ‘mipsel_24kc’ folder and it has empty/corrupt files which would account for the issue: http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/

    ]]>
    FS#2323: Meraki MR24 won't TFTP boot modern initramfs images https://bugs.openwrt.org/index.php?do=details&task_id=2323 2019-06-18T04:11:50Z Russell Senior Supply the following if possible: - Device problem occurs on Observed on Meraki MR24 - Software versions of OpenWrt/LEDE release, packages, etc. 18.06.2 and current HEAD - Steps to reproduce Attempt to TFTP boot an initramfs-kernel.bin image. => setenv meraki_bootfile openwrt-18.06.2-apm821xx-nand-meraki_mr24-initramfs-kernel.bin => setenv netloadmethod tftpboot; setenv bootargs console=ttyS0,${baudrate} rootfstype=squashfs mtdoops.mtddev=oops => run meraki_load_net meraki_checkpart meraki_bootlinux Waiting for PHY auto negotiation to complete.... done ENET Speed is 1000 Mbps - FULL duplex connection (EMAC0) Using ppc_4xx_eth0 device TFTP from server 192.168.80.7; our IP address is 192.168.80.49 Filename 'openwrt-18.06.2-apm821xx-nand-meraki_mr24-initramfs-kernel.bin'. Load address: 0xc00000 Loading: ################################################################# ################################################################# ################################################################# ################################################################# ############################### done Bytes transferred = 4262848 (410bc0 hex) Unexpected magic number 27051956 => Based on images in my built archive, seems the magic number (first four bytes of the initramfs-kernel.bin image) changed between 5244-gf0c37f6ceb and 6164-g9f5a4f8a42. Magic was previously: 8e 73 ed 8a, and those successfully boot. Sysupgrade images have been working fine, but this is the first time I’ve tried to tftp a recent image in a while. Supply the following if possible:
    - Device problem occurs on

    Observed on Meraki MR24

    - Software versions of OpenWrt/LEDE release, packages, etc.

    18.06.2 and current HEAD

    - Steps to reproduce

    Attempt to TFTP boot an initramfs-kernel.bin image.

    => setenv meraki_bootfile openwrt-18.06.2-apm821xx-nand-meraki_mr24-initramfs-kernel.bin
    => setenv netloadmethod tftpboot; setenv bootargs console=ttyS0,${baudrate} rootfstype=squashfs mtdoops.mtddev=oops
    => run meraki_load_net meraki_checkpart meraki_bootlinux
    Waiting for PHY auto negotiation to complete.... done
    ENET Speed is 1000 Mbps - FULL duplex connection (EMAC0)
    Using ppc_4xx_eth0 device
    TFTP from server 192.168.80.7; our IP address is 192.168.80.49
    Filename 'openwrt-18.06.2-apm821xx-nand-meraki_mr24-initramfs-kernel.bin'.
    Load address: 0xc00000
    Loading: #################################################################
             #################################################################
             #################################################################
             #################################################################
             ###############################
    done
    Bytes transferred = 4262848 (410bc0 hex)
    Unexpected magic number 27051956
    => 
    

    Based on images in my built archive, seems the magic number (first four bytes of the initramfs-kernel.bin image) changed between 5244-gf0c37f6ceb and 6164-g9f5a4f8a42. Magic was previously: 8e 73 ed 8a, and those successfully boot. Sysupgrade images have been working fine, but this is the first time I’ve tried to tftp a recent image in a while.

    ]]>
    FS#2322: Linksys 1900V2 compile kernel 4.14.125 broken https://bugs.openwrt.org/index.php?do=details&task_id=2322 2019-06-16T03:44:58Z Daniel Kang Supply the following if possible: - Device problem occurs on - Software versions of OpenWrt/LEDE release, packages, etc. - Steps to reproduce Supply the following if possible:
    - Device problem occurs on
    - Software versions of OpenWrt/LEDE release, packages, etc.
    - Steps to reproduce

     


    ]]>